<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head><link rel="stylesheet" href="//fonts.googleapis.com/css?family=Indie+Flower%7COpen+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700%7CRoboto%3A500%2C400italic%2C700%2C900%2C500italic%2C400%2C300" /><link rel="stylesheet" href="//cdn2.mikroe.com/theme/fonts/geogrotesque/geogrotesque-normal.css" type="text/css" media="all"><link rel="stylesheet" href="https://www.mikroe.com/wp-content/cache/min/1/997f307c62c810406e0dd28d457261d5.css" data-minify="1"/><link rel="stylesheet" href="https://www.mikroe.com/wp-content/cache/min/1/a7471d6294751f19e3ccbbb9b18700a8.css" data-minify="1"/><link rel="stylesheet" href="https://www.mikroe.com/wp-content/cache/min/1/14204ca4bd667e46103e64a7726ed7c4.css" data-minify="1"/><link rel="stylesheet" href="https://www.mikroe.com/wp-content/cache/min/1/3bffda37692f34ab14a3ed5d965ae10f.css" data-minify="1"/><link rel="stylesheet" href="https://www.mikroe.com/wp-content/cache/min/1/083425fd4d2aaa549724fcc8c1de31f3.css" data-minify="1"/><link rel="stylesheet" href="https://www.mikroe.com/wp-content/cache/min/1/c3850056b1cb356520d578e39dffc0c4.css" data-minify="1"/><link rel="stylesheet" href="https://www.mikroe.com/wp-content/cache/min/1/bb8fddb33087f5960e53f43e634a9005.css" data-minify="1"/><link rel="stylesheet" href="https://www.mikroe.com/wp-content/cache/min/1/a58bcd5771bbf8c5b06bf9d2b8d264a8.css" data-minify="1"/><link rel="stylesheet" href="https://www.mikroe.com/wp-content/cache/min/1/56d5fe5a6eaf2d126b53d2f33bed6b41.css" data-minify="1"/><link rel="stylesheet" href="https://www.mikroe.com/wp-content/cache/min/1/d4e5e5406ae502592fac646a8fb1c03c.css" data-minify="1"/><script type="text/javascript" src="//cdn.mikroe.com/themes/simplicity/js/jquery/jquery-2.1.4.min.js"></script><script type="text/javascript" src="//cdn.mikroe.com/themes/simplicity/js/jquery/jquery-migrate-1.2.1.min.js"></script><script type="text/javascript" src="//cdn.mikroe.com/themes/simplicity/js/velocity.min.js"></script><script id='st_insights_js' type='text/javascript' src='https://ws.sharethis.com/button/st_insights.js?publisher=4d48b7c5-0ae3-43d4-bfbe-3ff8c17a8ae6&#038;product=simpleshare'></script><script type="text/javascript" src="//cdn.mikroe.com/themes/simplicity/js/bowser.min.js" defer="defer"></script><script type="text/javascript" src="//cdn.mikroe.com/themes/simplicity/js/smartspinner.js" defer="defer"></script><script type="text/javascript" src="//cdn.mikroe.com/themes/simplicity/js/header-responsive.js" defer="defer"></script><script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2017Febaa'></script><script src="https://www.mikroe.com/wp-content/cache/min/1/16406921af272c8a163a19fd5aa1ba70.js" data-minify="1"></script><script src="https://www.mikroe.com/wp-content/cache/min/1/a336c02be8225a75cd2fbb01a224b21e.js" data-minify="1"></script><script src="https://www.mikroe.com/wp-content/cache/min/1/ad23d63ff89ae0bb8aa500bda6edf436.js" data-minify="1"></script>
    <title>A talking clock project with Text To Speech click - MikroElektronika</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://www.mikroe.com/xmlrpc.php" />

    <!-- ACA: me-global dependencies -->
    
    
    <!-- JQuery must be on top -->
    
    
    
    <!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="MkEoIbeL-XMSxMXKc1WSMfYTF9V_kdGCLfnRgkQdZSk" />
<meta property="og:image" content="https://cdn2.mikroe.com/img/2017/02/10121250/Artboard-1-100-2.jpg" /><meta name="author" content="Lana Vulic">
<link rel="icon" type="image/png" href="https://cdn2.mikroe.com/img/2016/11/16101212/mikroe-favicon.ico"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://cdn2.mikroe.com/img/2016/11/16123858/mikroe-logo-76x76.png"/><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://cdn2.mikroe.com/img/2016/11/16123927/mikroe-logo-120x120.png"/><link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://cdn2.mikroe.com/img/2016/11/16123950/mikroe-logo-152x152.png"/><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://cdn2.mikroe.com/img/2016/11/16123910/mikroe-logo-114x114.png"/><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://cdn2.mikroe.com/img/2016/11/16123939/mikroe-logo-144x144.png"/>
<!-- This site is optimized with the Yoast SEO plugin v4.2.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Theodor from electronza.com has made a project with our Text To Speech click board™, the Arduino Mega click shield, and RTC2 click and Proximity click."/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="https://www.mikroe.com/talking-clock-project-text-speech-click/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="A talking clock project with Text To Speech click - MikroElektronika" />
<meta property="og:description" content="Theodor from electronza.com has made a project with our Text To Speech click board™, the Arduino Mega click shield, and RTC2 click and Proximity click." />
<meta property="og:url" content="https://www.mikroe.com/talking-clock-project-text-speech-click/" />
<meta property="og:site_name" content="MikroElektronika" />
<meta property="article:tag" content="clock" />
<meta property="article:tag" content="RTC2 click" />
<meta property="article:tag" content="text to speech" />
<meta property="article:section" content="Click boards" />
<meta property="article:published_time" content="2017-02-10T12:46:38+01:00" />
<meta property="og:image" content="https://cdn2.mikroe.com/img/2017/02/10121250/Artboard-1-100-2.jpg" />
<meta property="og:image:width" content="1920" />
<meta property="og:image:height" content="1200" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Theodor from electronza.com has made a project with our Text To Speech click board™, the Arduino Mega click shield, and RTC2 click and Proximity click." />
<meta name="twitter:title" content="A talking clock project with Text To Speech click - MikroElektronika" />
<meta name="twitter:image" content="https://cdn2.mikroe.com/img/2017/02/10121250/Artboard-1-100-2.jpg" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//ws.sharethis.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="MikroElektronika &raquo; Feed" href="https://www.mikroe.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="MikroElektronika &raquo; Comments Feed" href="https://www.mikroe.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="MikroElektronika &raquo; A talking clock project with Text To Speech click Comments Feed" href="https://www.mikroe.com/talking-clock-project-text-speech-click/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.mikroe.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>




























<style id='__EPYT__style-inline-css' type='text/css'>

                .epyt-gallery-thumb {
                        width: 33.333%;
                }
                
</style>






<script type='text/javascript'>
/* <![CDATA[ */
var CrayonSyntaxSettings = {"version":"_2.7.2_beta","is_admin":"0","ajaxurl":"https:\/\/www.mikroe.com\/wp-admin\/admin-ajax.php","prefix":"crayon-","setting":"crayon-setting","selected":"crayon-setting-selected","changed":"crayon-setting-changed","special":"crayon-setting-special","orig_value":"data-orig-value","debug":""};
var CrayonSyntaxStrings = {"copy":"Press %s to Copy, %s to Paste","minimize":"Click To Expand Code"};
/* ]]> */
</script>


<script type='text/javascript'>
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"https:\/\/www.mikroe.com\/wp-admin\/admin-ajax.php","security":"df9df95092","gallery_scrolloffset":"20","eppathtoscripts":"https:\/\/www.mikroe.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","epresponsiveselector":"[\"iframe.__youtube_prefs_widget__\"]","epdovol":"1","version":"11.5","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]"};
/* ]]> */
</script>

<link rel='https://api.w.org/' href='https://www.mikroe.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.mikroe.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.mikroe.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.2" />
<link rel='shortlink' href='https://wp.me/p87352-1OU' />
<link rel="alternate" type="application/json+oembed" href="https://www.mikroe.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mikroe.com%2Ftalking-clock-project-text-speech-click%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.mikroe.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mikroe.com%2Ftalking-clock-project-text-speech-click%2F&#038;format=xml" />

<script type='text/javascript'>
	
	
(function() {
    var wa = document.createElement('script'); wa.type = 'text/javascript'; wa.async = true;
    wa.src = 'https://d10lpsik1i8c69.cloudfront.net/w.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(wa, s);
  })();
</script><script>(function(d, s, id){
                 var js, fjs = d.getElementsByTagName(s)[0];
                 if (d.getElementById(id)) {return;}
                 js = d.createElement(s); js.id = id;
                 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
                 fjs.parentNode.insertBefore(js, fjs);
               }(document, 'script', 'facebook-jssdk'));</script><style type="text/css">	.ssba {
									
									
									
									
								}
								.ssba img
								{
									width: 45px !important;
									padding: 6px;
									border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
								}
								.ssba, .ssba a
								{
									text-decoration:none;
									border:0;
									background: none;
									font-family: Indie Flower;
									font-size: 	20px;
									
									font-weight: bold;
								}
								</style>
<link rel='dns-prefetch' href='//v0.wordpress.com'>
<style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://www.mikroe.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]-->
<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

            if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
                htmlTag.className += ' td-md-is-iemobile';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_animation_stack_effect="type0";
var tds_animation_stack=true;
var td_animation_stack_specific_selectors=".entry-thumb, img";
var td_animation_stack_general_selectors=".td-animation-stack img, .post img";
var td_ajax_url="https:\/\/www.mikroe.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=7.5";
var td_get_template_directory_uri="https:\/\/www.mikroe.com\/wp-content\/themes\/Newspaper";
var tds_snap_menu="";
var tds_logo_on_sticky="";
var tds_header_style="";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="1";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#e61c24";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>


<!-- BEGIN GADWP v4.9.6.1 Universal Tracking - https://deconf.com/google-analytics-dashboard-wordpress/ -->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-2667377-1', 'auto');
  ga('send', 'pageview');
</script>

<!-- END GADWP Universal Tracking -->

<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript><script data-no-minify="1" data-cfasync="false">(function(w,d){function a(){var b=d.createElement("script");b.async=!0;b.src="https://www.mikroe.com/wp-content/plugins/wp-rocket/inc/front/js/lazyload.1.0.5.min.js";var a=d.getElementsByTagName("script")[0];a.parentNode.insertBefore(b,a)}w.attachEvent?w.attachEvent("onload",a):w.addEventListener("load",a,!1)})(window,document);</script></head>

<body class="post-template-default single single-post postid-7000 single-format-standard talking-clock-project-text-speech-click td-what single_template_2 white-menu wpb-js-composer js-comp-ver-5.0.1 vc_responsive td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Linkedin">
                <i class="td-icon-font td-icon-linkedin"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Vimeo">
                <i class="td-icon-font td-icon-vimeo"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-mikroe-globalnav-container"><ul id="menu-mikroe-globalnav" class="td-mobile-main-menu"><li id="menu-item-110" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first menu-item-110"><a href="/products/"><span class="me-gn-link-text">PRODUCTS</span></a></li>
<li id="menu-item-104" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104"><a href="https://shop.mikroe.com"><span class="me-gn-link-text">SHOP</span></a></li>
<li id="menu-item-105" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-105"><a href="https://learn.mikroe.com"><span class="me-gn-link-text">LEARN</span></a></li>
<li id="menu-item-505" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-505"><a href="http://docs.mikroe.com"><span class="me-gn-link-text">DOCS</span></a></li>
<li id="menu-item-108" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-108"><a href="https://libstock.mikroe.com/project_categories/"><span class="me-gn-link-text">LIBSTOCK</span></a></li>
<li id="menu-item-109" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-109"><a href="https://forum.mikroe.com"><span class="me-gn-link-text">FORUM</span></a></li>
<li id="menu-item-4783" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4783"><a href="https://helpdesk.mikroe.com"><span class="me-gn-link-text">HELP DESK</span></a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://www.mikroe.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap">
    
        <!--
Header style 1
-->
<!-- <div id="me-globalnav-banner">
	<div class="me-globalnav-banner-inner">
		<a href="https://shop.mikroe.com/?utm_source=header&utm_campaign=end-of-year-16&utm_medium=banner"><i class="fa fa-bell faa-shake animated"></i>End-of-year sale:</span> 15% DISCOUNT on all items until January 2. Applied at checkout.</a>
	</div>
	<div class="me-content-push"></div>	
	<div class="separator"></div>
</div> -->

<input type="checkbox" id="me-gn-menustate" class="me-gn-menustate" />
<nav id="me-globalnav">
	<div class="me-gn-content">
		<ul class="me-gn-header">
			<li class="me-gn-item me-gn-menuicon">
				<label class="me-gn-menuicon-label" for="me-gn-menustate" aria-hidden="true"> <span class="me-gn-menuicon-bread me-gn-menuicon-bread-top">
						<span class="me-gn-menuicon-bread-crust me-gn-menuicon-bread-crust-top"></span> </span> <span class="me-gn-menuicon-bread me-gn-menuicon-bread-bottom">
						<span class="me-gn-menuicon-bread-crust me-gn-menuicon-bread-crust-bottom"></span> </span>
				</label>
				<a href="#me-gn-menustate" class="me-gn-menuanchor me-gn-menuanchor-open" id="me-gn-menuanchor-open"> <span class="me-gn-menuanchor-label">Open Menu</span> </a>
				<a href="#" class="me-gn-menuanchor me-gn-menuanchor-close" id="me-gn-menuanchor-close" data-analytics-click="prefix:t,prop3:Close Menu"> <span class="me-gn-menuanchor-label">Close Menu</span> </a>
			</li>
			<li class="me-gn-item me-gn-mikroe">
				<a class="me-gn-link me-gn-link-mikroe" href="/" id="me-gn-firstfocus-small"></a>
			</li>
			<li class="me-gn-item me-gn-cart me-gn-cart-small" id="me-gn-cart-small">
				<a class="me-gn-link" href="https://shop.mikroe.com/order" aria-label="Shopping cart" role="button" aria-haspopup="true" aria-expanded="false" aria-controls="me-gn-cartview-content"><i class="fa fa-shopping-basket me-gn-icon-small"></i></a>
				<span class="me-gn-cartview-caret me-gn-cartview-caret-large"></span>
			</li>
		</ul>
		<ul id="menu-mikroe-globalnav-1" class="me-gn-list">	<li class="me-gn-item me-gn-mikroe">		<a class="me-gn-link me-gn-link-mikroe" href="/" id="me-gn-firstfocus"></a>	</li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-110"><a href="/products/"><span class="me-gn-link-text">PRODUCTS</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-104"><a href="https://shop.mikroe.com"><span class="me-gn-link-text">SHOP</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-105"><a href="https://learn.mikroe.com"><span class="me-gn-link-text">LEARN</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-505"><a href="http://docs.mikroe.com"><span class="me-gn-link-text">DOCS</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-108"><a href="https://libstock.mikroe.com/project_categories/"><span class="me-gn-link-text">LIBSTOCK</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-109"><a href="https://forum.mikroe.com"><span class="me-gn-link-text">FORUM</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-4783"><a href="https://helpdesk.mikroe.com"><span class="me-gn-link-text">HELP DESK</span></a></li>
	<li class="me-gn-item menu-item me-gn-search" role="search">		<a class="me-gn-link" href="#" aria-label="Product Search" role="button" aria-haspopup="true">			<i class="fa fa-search me-gn-icon-large"><span class="me-gn-search-placeholder" aria-hidden="true">Product Search</span></i>		</a>	</li>	<li class="me-gn-item menu-item me-gn-cart" id="me-gn-cart">		<a class="me-gn-link" href="https://shop.mikroe.com/order" aria-label="Shopping Cart" role="button" aria-haspopup="true" aria-expanded="false" aria-controls="me-gn-cartview-content">			<i class="fa me-gn-icon-large fa-shopping-basket"></i>			<span class="ajax_cart_quantity cart_count"></span>		</a>	</li></ul>		<aside id="me-gn-searchview" class="me-gn-searchview" role="search">
			<div class="me-gn-searchview-content">
				<form action="https://shop.mikroe.com/search" id="main_search" class="me-gn-searchform" method="post" accept-charset="utf-8">
					<div class="me-gn-searchform-wrapper">
						<input name="search_query" type="text" id="me-gn-searchform-input" value="" onfocus="" class="me-gn-searchform-input" placeholder="Search products" autocomplete="off" autocorrect="off" autocapitalize="off" spellcheck="false">
						<button id="me-gn-searchform-submit" class="me-gn-searchform-submit" type="submit" aria-label="Submit"></button>
						<button id="me-gn-searchform-reset" class="me-gn-searchform-reset" type="reset" aria-label="Clear Search"></button>
					</div>
					<div style="display:none;">
						<input name="controller" value="search" type="hidden">
						<input name="orderby" value="position" type="hidden">
						<input name="orderway" value="desc" type="hidden">
					</div>
				</form>
				<aside id="me-gn-searchresults" class="me-gn-searchresults"></aside>
			</div>
			<button id="me-gn-searchview-close" class="me-gn-searchview-close" aria-label="Close Search">
				<span class="me-gn-searchview-close-wrapper">
					<span class="me-gn-searchview-close-left"></span>
					<span class="me-gn-searchview-close-right"></span>
				</span>
			</button>
		</aside>
	</div>
</nav>
<div id="me-gn-curtain" class="me-gn-curtain"></div>
<div id="me-gn-placeholder" class="me-nav-placeholder"></div>
<div class="block-wrapper-full-page fixed on-top">
	<div class="container">
		<div id="mini_cart">
			<div style="display: none;" id="cart_block" class="mini_cart_style">
				<span>
					<div class="col-xs-12 col-sm-6 col-md-3 col-lg-3 cart-wrapper clearfix" style="float:right;">
						<div class="shopping_cart">
							<div class="cart_block exclusive">
								<div class="block_content">
									<div class="cart_block_list">
										<div class="cart-prices">
											<div class="cart-prices-line first-line">
												<span class="price ajax_block_products_total">$0.00</span>
												<span>
												Subtotal
												</span>
											</div>
										</div>
										<div class="cart-buttons">
											<a id="button_order_cart" class="btn btn-default button button-small" href="https://shop.mikroe.com/order" title="Checkout" rel="nofollow">
												<span>
												Check out<i class="icon-chevron-right right"></i>
												</span>
											</a>
										</div>
									</div>
								</div>
								<div class="cart-links">
									<ul class="cart-my-account-list">
										<li class="cart-my-account-item">
											<a id="mikroedropcart-drop-cart" onclick="mikroedropcartBlockcart(event);" class="empty-cart empty-cart" href="#" title="Empty cart" rel="nofollow" style="display: block;"><i class="fa fa-shopping-basket"></i>Empty cart</a>
										</li>
										<span id="blockcart-account-logged" class="">
											<li class="cart-my-account-item"><a href="https://shop.mikroe.com/module/blockwishlist/mywishlist" title="Wishlist"><i class="fa fa-heart"></i>Wishlist</a></li>
											<li class="cart-my-account-item"><a href="https://shop.mikroe.com/order-history" title="My orders" rel="nofollow"><i class="fa fa-cube"></i>Orders</a></li>
											<li class="cart-my-account-item"><a href="https://shop.mikroe.com/my-account" title="Sign in" rel="nofollow"><i class="fa fa-gear"></i>Account</a></li>
											<li class="cart-my-account-item"><a href="https://shop.mikroe.com/?mylogout" title="Sign out" rel="nofollow"><i class="fa fa-sign-out"></i>Sign out&nbsp;<span class="cart-customer-name"></span></a></li>
										</span>
										<span id="blockcart-account-not-logged" class="">
											<li class="cart-my-account-item"><a href="https://shop.mikroe.com/my-account" title="Sign in" rel="nofollow"><i class="fa fa-user"></i>Sign in</a></li>
										</span>
									</ul>
								</div>
							</div>
						</div>
					</div>
				</span>
			</div>
		</div>
	</div>
</div>

<div id="me-gn-viewport-emitter"> </div>
<div class="td-main-content-wrap">

    <div class="td-container td-post-template-2">
        <article id="post-7000" class="post-7000 post type-post status-publish format-standard has-post-thumbnail hentry category-click-boards tag-clock tag-rtc2-click tag-text-to-speech" itemscope itemtype="https://schema.org/Article">
            <div class="td-pb-row">
                <div class="td-pb-span12">
                    <div class="td-post-header">
                        <div class="td-crumb-container"><div class="entry-crumbs" itemscope itemtype="http://schema.org/BreadcrumbList"><span itemscope itemprop="itemListElement" itemtype="http://schema.org/ListItem">
                               <a title="" class="entry-crumb" itemscope itemprop="item" itemtype="http://schema.org/Thing" href="https://www.mikroe.com/">
                                  <span itemprop="name">Home</span>    </a>    <meta itemprop="position" content = "1"></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemprop="itemListElement" itemtype="http://schema.org/ListItem">
                               <a title="View all posts in Click boards" class="entry-crumb" itemscope itemprop="item" itemtype="http://schema.org/Thing" href="https://www.mikroe.com/category/click-boards/">
                                  <span itemprop="name">Click boards</span>    </a>    <meta itemprop="position" content = "2"></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">A talking clock project with Text To Speech click</span></div></div>

                        <ul class="td-category"><li class="entry-category"><a  href="https://www.mikroe.com/category/click-boards/">Click boards</a></li></ul>
                        <header class="td-post-title">
                            <h1 class="entry-title">A talking clock project with Text To Speech click</h1>

                            

                            <div class="td-module-meta-info">
                                <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.mikroe.com/author/lana-vulic/">Lana Vulic</a><div class="td-author-line"> - </div> </div>                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-02-10T12:46:38+00:00" >10th February 2017</time></span>                                <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-7000">1</span></div>                                <div class="td-post-comments"><a href="https://www.mikroe.com/talking-clock-project-text-speech-click/#respond"><i class="td-icon-comments"></i>0</a></div>                            </div>

                        </header>
                    </div>
                </div>
            </div> <!-- /.td-pb-row -->

            <div class="td-pb-row">
                                            <div class="td-pb-span8 td-main-content" role="main">
                                <div class="td-ss-main-content">
                                    
        

        <div class="td-post-content">
            <div class="td-post-featured-image"><a href="https://cdn2.mikroe.com/img/2017/02/10121250/Artboard-1-100-2.jpg" data-caption=""><img width="766" height="479" class="entry-thumb td-modal-image" src="https://cdn2.mikroe.com/img/2017/02/10121250/Artboard-1-100-2-766x479.jpg" srcset="https://cdn2.mikroe.com/img/2017/02/10121250/Artboard-1-100-2-766x479.jpg 766w, https://cdn2.mikroe.com/img/2017/02/10121250/Artboard-1-100-2-1532x958.jpg 1532w" sizes="(-webkit-min-device-pixel-ratio: 2) 1532px, (min-resolution: 192dpi) 1532px, (max-width: 768px) 1532px, 766px" alt="Talking clock project news banner" title="Talking clock project news banner"/></a></div>
            <p>Imagine this: you move your hand above a small device and it tells you the time, out loud. No need to take out your phone, or direct your eyes to the nearest clock.</p>
<p>Well, this can be a reality if you read the <a href="https://electronza.com/arduino-talking-clock-s1v30120/">tutorial</a> Theodor from electronza.com has made with our <a href="https://shop.mikroe.com/click/audio-and-voice/text-to-speech">Text To Speech click board™</a>, the <a href="https://shop.mikroe.com/add-on-boards/click-shields/arduino-mega-click-shield">Arduino Mega click shield</a>, <a href="https://shop.mikroe.com/click/clock-and-timing/rtc-2">RTC2 click</a>, <a href="https://shop.mikroe.com/click/sensors/proximity">Proximity click</a> and the Arduino Mega.</p>
<h3>Building the hardware</h3>
<p>Building the hardware is going to be the easiest part of this tutorial. Theodor describes the process rather well:</p>
<p><img data-attachment-id="7009" data-permalink="https://www.mikroe.com/talking-clock-project-text-speech-click/talking-click-arduino-s1v30120-vcnl4010-parts-copy-1/" data-orig-file="https://cdn2.mikroe.com/img/2017/02/10121736/talking-click-arduino-s1v30120-vcnl4010-parts-copy-1.jpg" data-orig-size="1200,574" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="talking clock project text to speech click" data-image-description="" data-medium-file="https://cdn2.mikroe.com/img/2017/02/10121736/talking-click-arduino-s1v30120-vcnl4010-parts-copy-1-300x144.jpg" data-large-file="https://cdn2.mikroe.com/img/2017/02/10121736/talking-click-arduino-s1v30120-vcnl4010-parts-copy-1-1024x490.jpg" class="wp-image-7009 aligncenter" src="https://cdn2.mikroe.com/img/2017/02/10121736/talking-click-arduino-s1v30120-vcnl4010-parts-copy-1-300x144.jpg" alt="talking clock project text to speech click" width="475" height="228" srcset="https://cdn2.mikroe.com/img/2017/02/10121736/talking-click-arduino-s1v30120-vcnl4010-parts-copy-1-300x144.jpg 300w, https://cdn2.mikroe.com/img/2017/02/10121736/talking-click-arduino-s1v30120-vcnl4010-parts-copy-1-768x367.jpg 768w, https://cdn2.mikroe.com/img/2017/02/10121736/talking-click-arduino-s1v30120-vcnl4010-parts-copy-1-1024x490.jpg 1024w, https://cdn2.mikroe.com/img/2017/02/10121736/talking-click-arduino-s1v30120-vcnl4010-parts-copy-1-766x366.jpg 766w, https://cdn2.mikroe.com/img/2017/02/10121736/talking-click-arduino-s1v30120-vcnl4010-parts-copy-1-1170x560.jpg 1170w, https://cdn2.mikroe.com/img/2017/02/10121736/talking-click-arduino-s1v30120-vcnl4010-parts-copy-1-878x420.jpg 878w, https://cdn2.mikroe.com/img/2017/02/10121736/talking-click-arduino-s1v30120-vcnl4010-parts-copy-1.jpg 1200w" sizes="(max-width: 475px) 100vw, 475px" /></p>
<blockquote><p>“As usual with MikroElektronika click boards, building the hardware is just like playing with Lego bricks.”</p></blockquote>
<p>Place the Text To Speech click in the first socket, and the other two clicks can be placed in the remaining two sockets in the order of your choice since they both use I2C communication.</p>
<h3>Talking clock code</h3>
<p>The second part of the <a href="https://electronza.com/arduino-talking-clock-s1v30120/2/">tutorial</a> will take you step by step through the programming of your future talking clock. Find out how to set the precise time, how to change the pin definitions to match the Arduino Mega pinout and more.</p>
<p>Finally, in the <a href="https://electronza.com/arduino-talking-clock-s1v30120/3/">third part</a>, you can see the final code for the project. You can click on the code snippet to expand it, or download the code directly from the page.</p>
<h3>Text To Speech click</h3>
<p>Our Text To Speech click speaks English and Spanish in two dialects – Castilian Spanish and Latin American Spanish. How many languages do you speak?</p>
<p>The click carries an Epson S1V30120 speech synthesis IC, powered by the the Fonix DECtalk® v5 speech synthesis engine.</p>
<p>For more information about <strong>Text To Speech click</strong>, check out the <a href="https://shop.mikroe.com/click/audio-and-voice/text-to-speech">product page</a>.</p>
<p>Yours Sincerely,<br />
MikroElektronika</p>
<!-- Simple Share Buttons Adder (6.3.4) simplesharebuttons.com --><div class="ssba ssba-wrap"><div style="text-align:left"><a data-site="" class="ssba_facebook_share" href="http://www.facebook.com/sharer.php?u=https://www.mikroe.com/talking-clock-project-text-speech-click/"  target="_blank" ><img src="https://www.mikroe.com/wp-content/plugins/simple-share-buttons-adder/buttons/simple/facebook.png" title="Facebook" class="ssba ssba-img" alt="Share on Facebook" /></a><a data-site="" class="ssba_google_share" href="https://plus.google.com/share?url=https://www.mikroe.com/talking-clock-project-text-speech-click/"  target="_blank" ><img src="https://www.mikroe.com/wp-content/plugins/simple-share-buttons-adder/buttons/simple/google.png" title="Google+" class="ssba ssba-img" alt="Share on Google+" /></a><a data-site="" class="ssba_twitter_share" href="http://twitter.com/share?url=https://www.mikroe.com/talking-clock-project-text-speech-click/&amp;text=A+talking+clock+project+with+Text+To+Speech+click+"  target="_blank" ><img src="https://www.mikroe.com/wp-content/plugins/simple-share-buttons-adder/buttons/simple/twitter.png" title="Twitter" class="ssba ssba-img" alt="Tweet about this on Twitter" /></a><a data-site="linkedin" class="ssba_linkedin_share ssba_share_link" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.mikroe.com/talking-clock-project-text-speech-click/"  target="_blank" ><img src="https://www.mikroe.com/wp-content/plugins/simple-share-buttons-adder/buttons/simple/linkedin.png" title="LinkedIn" class="ssba ssba-img" alt="Share on LinkedIn" /></a></div></div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://www.mikroe.com/tag/clock/">clock</a></li><li><a href="https://www.mikroe.com/tag/rtc2-click/">RTC2 click</a></li><li><a href="https://www.mikroe.com/tag/text-to-speech/">text to speech</a></li></ul>            </div>

                        <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.mikroe.com/only-5-minutes-for-accurate-readings-air-quality-2-click/">Only 5 minutes for accurate readings &#8211; Air quality 2 click</a></div></div><div class="td-next-prev-separator"></div></div>            <div class="author-box-wrap"><a href="https://www.mikroe.com/author/lana-vulic/"><img alt='' src='https://secure.gravatar.com/avatar/0e9953acc3925fc6a2529d6bbf24d378?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/0e9953acc3925fc6a2529d6bbf24d378?s=192&amp;d=mm&amp;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://www.mikroe.com/author/lana-vulic/">Lana Vulic</a></span></div><div class="td-author-url"><a href="http://www.mikroe.com">http://www.mikroe.com</a></div><div class="td-author-description"></div><div class="td-author-social"></div><div class="clearfix"></div></div></div>	        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Lana Vulic"></span><meta itemprop="datePublished" content="2017-02-10T12:46:38+00:00"><meta itemprop="dateModified" content="2017-02-10T12:46:38+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.mikroe.com/talking-clock-project-text-speech-click/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content=""></span><meta itemprop="name" content="MikroElektronika"></span><meta itemprop="headline " content="A talking clock project with Text To Speech click"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://cdn2.mikroe.com/img/2017/02/10121250/Artboard-1-100-2.jpg"><meta itemprop="width" content="1920"><meta itemprop="height" content="1200"></span>        </footer>

    <div class="td_block_wrap td_block_related_posts td_uid_1_589da826171eb_rand td_with_ajax_pagination td-pb-border-top"  data-td-block-uid="td_uid_1_589da826171eb" ><script>var block_td_uid_1_589da826171eb = new tdBlock();
block_td_uid_1_589da826171eb.id = "td_uid_1_589da826171eb";
block_td_uid_1_589da826171eb.atts = '{"limit":3,"sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"next_prev","header_color":"","header_text_color":"","ajax_pagination_infinite_stop":"","td_column_number":3,"td_ajax_preloading":"","td_ajax_filter_type":"td_custom_related","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_uid_1_589da826171eb_rand","el_class":"","offset":"","css":"","live_filter":"cur_post_same_tags","live_filter_cur_post_id":7000,"live_filter_cur_post_author":"8"}';
block_td_uid_1_589da826171eb.td_column_number = "3";
block_td_uid_1_589da826171eb.block_type = "td_block_related_posts";
block_td_uid_1_589da826171eb.post_count = "1";
block_td_uid_1_589da826171eb.found_posts = "1";
block_td_uid_1_589da826171eb.header_color = "";
block_td_uid_1_589da826171eb.ajax_pagination_infinite_stop = "";
block_td_uid_1_589da826171eb.max_num_pages = "1";
tdBlocksArray.push(block_td_uid_1_589da826171eb);
</script><h4 class="td-related-title"><a id="td_uid_2_589da82619d60" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_1_589da826171eb" href="#">RELATED ARTICLES</a><a id="td_uid_3_589da82619e0e" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_1_589da826171eb" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_1_589da826171eb class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.mikroe.com/text-to-speech-click-released-with-a-new-platform-for-product-documentation/" rel="bookmark" title="Text To Speech click released, with a new platform for product documentation"><img width="241" height="166" class="entry-thumb" src="https://cdn2.mikroe.com/img/2016/04/19165444/maxresdefault-241x166.jpg" srcset="https://cdn2.mikroe.com/img/2016/04/19165444/maxresdefault-241x166.jpg 241w, https://cdn2.mikroe.com/img/2016/04/19165444/maxresdefault-482x332.jpg 482w" sizes="(-webkit-min-device-pixel-ratio: 2) 482px, (min-resolution: 192dpi) 482px, (max-width: 768px) 482px, 241px" alt="" title="Text To Speech click released, with a new platform for product documentation"/><span class="td-video-play-ico"><img width="40" height="40" class="td-retina" src="https://www.mikroe.com/wp-content/themes/Newspaper/images/icons/ico-video-large.png" alt="video"/></span></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.mikroe.com/text-to-speech-click-released-with-a-new-platform-for-product-documentation/" rel="bookmark" title="Text To Speech click released, with a new platform for product documentation">Text To Speech click released, with a new platform for product documentation</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_589da826171eb" data-td_block_id="td_uid_1_589da826171eb"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page ajax-page-disabled" id="next-page-td_uid_1_589da826171eb" data-td_block_id="td_uid_1_589da826171eb"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->

	<div class="comments" id="comments">
        	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/talking-clock-project-text-speech-click/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://www.mikroe.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<div class="clearfix"></div>
				<p class="comment-form-input-wrap td-form-comment">
					<textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
		        </p><p class="comment-form-input-wrap td-form-author">
			            <span class="comment-req-wrap">
			            	<input class="" id="author" name="author" placeholder="Name:" type="text" value="" size="30" /></span></p>
<p class="comment-form-input-wrap td-form-email">
			            <span class="comment-req-wrap"><input class="" id="email" name="email" placeholder="Email:" type="text" value="" size="30" /></span></p>
<p class="comment-form-input-wrap td-form-url">
			            <input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" /></p>
<div class="anr_captcha_field"><div id="anr_captcha_field_1"></div></div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='7000' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="a06b1bc2dc" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="42"/></p>			</form>
			</div><!-- #respond -->
	    </div> <!-- /.content -->
                                </div>
                            </div>
                            <div class="td-pb-span4 td-main-sidebar" role="complementary">
                                <div class="td-ss-main-sidebar">
                                    <aside class="widget widget_search"><div class="block-title"><span>Search Articles</span></div><form method="get" class="td-search-form-widget" action="https://www.mikroe.com/">
    <div role="search">
        <input class="td-widget-search-input" type="text" value="" name="s" id="s" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit" value="Search" />
    </div>
</form></aside><div class="td_block_wrap td_block_popular_categories td_block_widget td_uid_4_589da8261ed78_rand widget widget_categories td-pb-border-top"  data-td-block-uid="td_uid_4_589da8261ed78" ><h4 class="block-title"><span>POPULAR CATEGORIES</span></h4><ul class="td-pb-padding-side"><li><a href="https://www.mikroe.com/category/releases/">Releases<span class="td-cat-no">1233</span></a></li><li><a href="https://www.mikroe.com/category/click-boards/">Click boards<span class="td-cat-no">100</span></a></li><li><a href="https://www.mikroe.com/category/community-news/">Community news<span class="td-cat-no">89</span></a></li><li><a href="https://www.mikroe.com/category/hexiwear/">Hexiwear<span class="td-cat-no">59</span></a></li><li><a href="https://www.mikroe.com/category/mikromedia/">Mikromedia<span class="td-cat-no">28</span></a></li><li><a href="https://www.mikroe.com/category/offers/">Offers<span class="td-cat-no">20</span></a></li><li><a href="https://www.mikroe.com/category/compilers/">Compilers<span class="td-cat-no">20</span></a></li><li><a href="https://www.mikroe.com/category/learn/">Learn<span class="td-cat-no">18</span></a></li><li><a href="https://www.mikroe.com/category/distributors/">Distributors<span class="td-cat-no">8</span></a></li><li><a href="https://www.mikroe.com/category/kits/">Kits<span class="td-cat-no">7</span></a></li></ul></div> <!-- ./block --><aside class="widget widget_twitter_timeline"><div class="block-title"><span>Follow us on Twitter</span></div><a class="twitter-timeline" data-height="400" data-theme="light" data-link-color="#f96e5b" data-border-color="#e8e8e8" data-tweet-limit="3" data-lang="EN" data-partner="jetpack" data-chrome="noheader nofooter noborders transparent" href="https://twitter.com/mikroel">My Tweets</a></aside><aside class="widget widget_jetpack_display_posts_widget"><div class="block-title"><span>MikroElektronika Learn</span></div><div class="jetpack-display-remote-posts"><h4><a href="http://learn.mikroe.com/hexiwear-and-gsm4/" target="_blank">Enhance Hexiwear with GSM 4 click</a></h4>
<a title="Enhance Hexiwear with GSM 4 click" href="http://learn.mikroe.com/hexiwear-and-gsm4/" target="_blank"><img src="https://i1.wp.com/cdn.mikroe.com/knowlegebase/uploads/2016/12/19171623/18-hexiwear-communicates-sms-banner-news.jpg" alt="Enhance Hexiwear with GSM 4 click"/></a><h4><a href="http://learn.mikroe.com/fingerprint-click-complete-biometric-solution/" target="_blank">Fingerprint click &#8211; the complete biometric solution</a></h4>
<a title="Fingerprint click &#8211; the complete biometric solution" href="http://learn.mikroe.com/fingerprint-click-complete-biometric-solution/" target="_blank"><img src="https://i0.wp.com/cdn.mikroe.com/knowlegebase/uploads/2016/12/07104010/fingerprint_click_021.png" alt="Fingerprint click &#8211; the complete biometric solution"/></a><h4><a href="http://learn.mikroe.com/rn52-media-station/" target="_blank">RN52 Media Station</a></h4>
<a title="RN52 Media Station" href="http://learn.mikroe.com/rn52-media-station/" target="_blank"><img src="https://i1.wp.com/cdn.mikroe.com/knowlegebase/uploads/2016/10/10164748/bt-audio-click-learn.jpg" alt="RN52 Media Station"/></a></div><!-- .jetpack-display-remote-posts --></aside>                                </div>
                            </div>
                                    </div> <!-- /.td-pb-row -->
        </article> <!-- /.post -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->


<!-- Instagram -->



<!-- Footer -->
<div id="me-gn-footer" class="td-footer-wrapper" role="contentinfo">
    <div class="first">
        <div class="td-container">
            <div class="footer-section sidebar-4 col-lg-12 col-md-12 col-sm-12 col-xs-12">
                <aside class="widget zoom-social-icons-widget"><div class="block-title"><span>Follow us</span></div>
        
        <ul class="zoom-social-icons-list zoom-social-icons-list--without-canvas zoom-social-icons-list--rounded zoom-social-icons-list--no-labels">

            
                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://www.facebook.com/mikroElektronika/" target="_blank">
                                                                                                <span class="socicon socicon-facebook"
                              style="color:#ffffff; font-size: 18px; padding:8px"></span>

                                            </a>
                </li>

            
                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://twitter.com/mikroel/" target="_blank">
                                                                                                <span class="socicon socicon-twitter"
                              style="color:#ffffff; font-size: 18px; padding:8px"></span>

                                            </a>
                </li>

            
                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://plus.google.com/u/0/+mikroelektronika/" target="_blank">
                                                                                                <span class="socicon socicon-google"
                              style="color:#ffffff; font-size: 18px; padding:8px"></span>

                                            </a>
                </li>

            
                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://www.linkedin.com/company/mikroelektronika" target="_blank">
                                                                                                <span class="socicon socicon-linkedin"
                              style="color:#ffffff; font-size: 18px; padding:8px"></span>

                                            </a>
                </li>

            
                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://github.com/MikroElektronika/" target="_blank">
                                                                                                <span class="socicon socicon-github"
                              style="color:#ffffff; font-size: 18px; padding:8px"></span>

                                            </a>
                </li>

            
                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://www.youtube.com/user/mikroElektronika/" target="_blank">
                                                                                                <span class="socicon socicon-youtube"
                              style="color:#ffffff; font-size: 18px; padding:8px"></span>

                                            </a>
                </li>

            
        </ul>

        </aside><aside class="widget widget_mc4wp_form_widget"><div class="block-title"><span>Subscribe to newsletter</span></div><script type="text/javascript">(function() {
	if (!window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push({
						event   : event,
						callback: callback
					});
				}
			}
		}
	}
})();
</script><!-- MailChimp for WordPress v4.0.13 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-347" method="post" data-id="347" data-name="Newsletter" ><div class="mc4wp-form-fields"><input type="email" name="EMAIL" placeholder="Enter Email Address" required><i class="fa fa-chevron-circle-right"></i><input type="submit" value="">

<div style="display: none;"><input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></div><input type="hidden" name="_mc4wp_timestamp" value="1486727206" /><input type="hidden" name="_mc4wp_form_id" value="347" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /></div><div class="mc4wp-response"></div></form><!-- / MailChimp for WordPress Plugin --></aside>            </div>
        </div>
    </div>
    <div class="second">
        <div class="td-container">
            <div class="footer-section sidebar-3 col-lg-12 col-md-12 col-sm-12 col-xs-12">
                <aside class="widget widget_nav_menu"><div class="block-title"><span>Looking for a specific architecture?</span></div><div class="menu-toolchains-container"><ul id="menu-toolchains" class="menu"><li id="menu-item-6472" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-6472"><a href="https://www.mikroe.com/pic/"><div><span>PIC</span></div></a></li>
<li id="menu-item-6473" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-6473"><a href="https://www.mikroe.com/pic32/"><div><span>PIC32</span></div></a></li>
<li id="menu-item-6469" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-6469"><a href="https://www.mikroe.com/dspic/"><div><span>dsPIC</span></div></a></li>
<li id="menu-item-6467" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-6467"><a href="https://www.mikroe.com/avr/"><div><span>AVR</span></div></a></li>
<li id="menu-item-6466" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-6466"><a href="https://www.mikroe.com/8051-2/"><div><span>8051</span></div></a></li>
<li id="menu-item-6470" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-6470"><a href="https://www.mikroe.com/ft90x/"><div><span>FT90x</span></div></a></li>
<li id="menu-item-6475" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-6475"><a href="https://www.mikroe.com/stm32/"><div><span>STM32</span></div></a></li>
<li id="menu-item-6471" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-6471"><a href="https://www.mikroe.com/kinetis/"><div><span>Kinetis</span></div></a></li>
<li id="menu-item-6476" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-6476"><a href="https://www.mikroe.com/tiva/"><div><span>Tiva</span></div></a></li>
<li id="menu-item-6468" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-6468"><a href="https://www.mikroe.com/cec1302/"><div><span>CEC</span></div></a></li>
<li id="menu-item-6474" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-6474"><a href="https://www.mikroe.com/psoc/"><div><span>PSoC</span></div></a></li>
<li id="menu-item-6477" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6477"><a href="/msp432/"><div><span>MSP432</span></div></a></li>
</ul></div></aside>            </div>
        </div>
    </div>
    <div class="third">
        <div class="td-container">
            <div class="footer-section sidebar-1 col-lg-6 col-md-6 col-sm-12 col-xs-12">
                <aside class="widget widget_nav_menu"><div class="block-title"><span>About Us</span></div><div class="menu-about-us-container"><ul id="menu-about-us" class="menu"><li id="menu-item-6461" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-6461"><a href="https://www.mikroe.com/about/">Company facts</a></li>
<li id="menu-item-6464" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-6464"><a href="https://www.mikroe.com/about/leadership/">Leadership</a></li>
<li id="menu-item-6462" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-6462"><a href="https://www.mikroe.com/about/hq/">Headquarters</a></li>
<li id="menu-item-6463" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-6463"><a href="https://www.mikroe.com/about/history/">History</a></li>
<li id="menu-item-6882" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-6882"><a href="https://www.mikroe.com/distributors/">Distributors</a></li>
</ul></div></aside><aside class="widget widget_nav_menu"><div class="block-title"><span>Contact Us</span></div><div class="menu-contact-us-container"><ul id="menu-contact-us" class="menu"><li id="menu-item-232" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-232"><a href="https://helpdesk.mikroe.com">Submit a Ticket</a></li>
<li id="menu-item-233" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-233"><a href="https://www.mikroe.com/visitor_contacts/">Online Contact Form</a></li>
<li id="menu-item-234" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-234"><a href="https://www.mikroe.com/customization/">Request Customization</a></li>
<li id="menu-item-235" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-235"><a href="https://www.mikroe.com/internships/">Apply for Internship</a></li>
<li id="menu-item-236" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-236"><a href="https://www.mikroe.com/site-license/">Site License Inquiry</a></li>
</ul></div></aside><aside class="widget widget_nav_menu"><div class="block-title"><span>Community</span></div><div class="menu-community-container"><ul id="menu-community" class="menu"><li id="menu-item-6456" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-6456"><a href="https://forum.mikroe.com">Forum</a></li>
<li id="menu-item-6457" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6457"><a href="http://www.hexiwear.com">Hexiwear</a></li>
<li id="menu-item-6458" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6458"><a href="https://libstock.mikroe.com/project_categories/">Libstock</a></li>
<li id="menu-item-6459" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6459"><a href="https://learn.mikroe.com">Learn</a></li>
</ul></div></aside>            </div>
            <div class="footer-section sidebar-2 col-lg-6 col-md-6 col-sm-12 col-xs-12">
                <aside class="widget widget_custom_post_widget"><div class="block-title"><span>Got questions? Ask away</span></div><div role="form" class="wpcf7" id="wpcf7-f6430-p7000-o1" lang="en-US" dir="ltr">
<div class="screen-reader-response"></div>
<form action="/talking-clock-project-text-speech-click/#wpcf7-f6430-p7000-o1" method="post" class="wpcf7-form" novalidate="novalidate">
<div style="display: none;">
<input type="hidden" name="_wpcf7" value="6430" />
<input type="hidden" name="_wpcf7_version" value="4.6.1" />
<input type="hidden" name="_wpcf7_locale" value="en_US" />
<input type="hidden" name="_wpcf7_unit_tag" value="wpcf7-f6430-p7000-o1" />
<input type="hidden" name="_wpnonce" value="b467ba5ff6" />
</div>
<div class="me-footer-contact-form">
<div class="row">
<div class="message col-xs-12 col-sm-12 col-md-12 col-lg-12">
		    <span class="wpcf7-form-control-wrap your-message"><textarea name="your-message" cols="40" rows="10" maxlength="700" minlength="20" class="wpcf7-form-control wpcf7-textarea wpcf7-validates-as-required sidebarinput" id="me-footer-contact-message" aria-required="true" aria-invalid="false" placeholder="Type your message here"></textarea></span>
		</div></div>
<div class="row">
<div class="email col-xs-12 col-sm-12 col-md-4 col-lg-5">
		    <label for="me-footer-contact-email">Your Email*:</label><br />
		    <span class="wpcf7-form-control-wrap your-email"><input type="email" name="your-email" value="" size="40" class="wpcf7-form-control wpcf7-text wpcf7-email wpcf7-validates-as-required wpcf7-validates-as-email sidebarinput" id="me-footer-contact-email" aria-required="true" aria-invalid="false" placeholder="Enter your email address" /></span>
		</div>
<div class="department col-xs-12 col-sm-12 col-md-4 col-lg-4">
		    <label for="me-footer-contact-department">For which department?*</label><br />
		    <span class="wpcf7-form-control-wrap your-recipient"><select name="your-recipient" class="wpcf7-form-control wpcf7-select wpcf7-validates-as-required" id="me-footer-contact-department" aria-required="true" aria-invalid="false"><option value="General">General</option><option value="Sales">Sales</option><option value="Support">Support</option></select></span>
		</div>
<div class="send-button col-xs-12 col-sm-12 col-md-4 col-lg-3">
		    <input type="submit" value="Submit" class="wpcf7-form-control wpcf7-submit" />
		</div>
<p>                <span class="wpcf7-form-control-wrap your-country-wrap" style="display:none !important; visibility:hidden !important;"><input class="wpcf7-form-control wpcf7-text"  type="text" name="your-country" value="" size="40" tabindex="-1" /><span class="hp-message">Please leave this field empty.</span></span>
	</p></div>
</div>
<div class="wpcf7-response-output wpcf7-display-none"></div></form></div>
<!-- Simple Share Buttons Adder (6.3.4) simplesharebuttons.com --><div class="ssba ssba-wrap"><div style="text-align:left"><a data-site="" class="ssba_facebook_share" href="http://www.facebook.com/sharer.php?u=https://www.mikroe.com/talking-clock-project-text-speech-click/"  target="_blank" ><img src="https://www.mikroe.com/wp-content/plugins/simple-share-buttons-adder/buttons/simple/facebook.png" title="Facebook" class="ssba ssba-img" alt="Share on Facebook" /></a><a data-site="" class="ssba_google_share" href="https://plus.google.com/share?url=https://www.mikroe.com/talking-clock-project-text-speech-click/"  target="_blank" ><img src="https://www.mikroe.com/wp-content/plugins/simple-share-buttons-adder/buttons/simple/google.png" title="Google+" class="ssba ssba-img" alt="Share on Google+" /></a><a data-site="" class="ssba_twitter_share" href="http://twitter.com/share?url=https://www.mikroe.com/talking-clock-project-text-speech-click/&amp;text=A+talking+clock+project+with+Text+To+Speech+click+"  target="_blank" ><img src="https://www.mikroe.com/wp-content/plugins/simple-share-buttons-adder/buttons/simple/twitter.png" title="Twitter" class="ssba ssba-img" alt="Tweet about this on Twitter" /></a><a data-site="linkedin" class="ssba_linkedin_share ssba_share_link" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.mikroe.com/talking-clock-project-text-speech-click/"  target="_blank" ><img src="https://www.mikroe.com/wp-content/plugins/simple-share-buttons-adder/buttons/simple/linkedin.png" title="LinkedIn" class="ssba ssba-img" alt="Share on LinkedIn" /></a></div></div></aside>            </div>
        </div>
    </div>

    <div class="fourth footer-bottom col-lg-12 col-md-12 col-sm-12 col-xs-12">
        <ul id="serbian">
            <li class="footer-copyright"><img class="flag" width="20" src="https://cdn.mikroe.com/themes/simplicity/img/flags/4x3/rs.svg" title="Serbia">© 1998 - 2017 MikroElektronika d.o.o.</li>
            <li>
                <ul id="menu-mikroe-footer-serbian-menu" class="me-footer-serbian-menu"><li id="menu-item-6450" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-6450"><a href="https://shop.mikroe.com/rs">Prodavnica</a></li>
<li id="menu-item-6451" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6451"><a href="/jobs/">Zaposlenje</a></li>
<li id="menu-item-6452" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6452"><a href="/napravi-click/">Napravi click</a></li>
<li id="menu-item-6453" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6453"><a href="/praksa/">Stručna praksa</a></li>
<li id="menu-item-6454" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6454"><a href="https://shop.mikroe.com/rs/info/policies/terms-and-conditions-of-sale">Uslovi prodaje</a></li>
<li id="menu-item-6455" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6455"><a href="https://shop.mikroe.com/rs/info/policies/privacy-policy">Privatnost</a></li>
</ul>            </li>
        </ul>
        <ul id="global">
            <li class="footer-copyright">Copyright © 1998 - 2017 MikroElektronika d.o.o.</li>
            <li>
                <ul id="menu-mikroe-footer-global-menu" class="me-footer-global-menu"><li id="menu-item-6478" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-6478"><a href="https://shop.mikroe.com/info/policies/terms-and-conditions-of-sale">Terms and Conditions</a></li>
<li id="menu-item-6479" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-6479"><a href="https://shop.mikroe.com/info/policies/privacy-policy">Privacy</a></li>
</ul>            </li>
            <li class="payment-logos">
              <p><a href="https://2checkout.com" target="_blank"><img alt="2Checkout Supported Credit Carts" src="//cdn-shop.mikroe.com/themes/me-simplicity/img/2co-payment-options.png" height="33px" width="335px"></a></p>
            </li>
        </ul>
    </div>
</div>



</div><!--close td-outer-wrap-->

	<script type="text/javascript">
      var anr_onloadCallback = function() {
	  				var anr_captcha_1;
				anr_captcha_1 = grecaptcha.render('anr_captcha_field_1', {
				  'sitekey' : '6LfD3BITAAAAAIyL3fFkCYuF_JK7lDV8zgXcH7xe',
				  'theme' : 'light',
				  'size' : 'normal'
				});
		      };
    </script>
	<script src="https://www.google.com/recaptcha/api.js?onload=anr_onloadCallback&render=explicit&amp;hl=en"
        async defer>
    </script>

			<div style="display:none">
	<div class="grofile-hash-map-0e9953acc3925fc6a2529d6bbf24d378">
	</div>
	</div>


    <!--

        Theme: Newspaper by tagDiv 2016
        Version: 7.5 (rara)
        Deploy mode: deploy
        
        uid: 589da82637487
    -->

    
<!-- Custom css form theme panel -->
<style type="text/css" media="screen">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</style>

<script type="text/javascript">$(document).ready(function() {
    $('.me-fancy-banner.me-hexiwear-home-banner-001').click(function(e){
         e.preventDefault();
         window.location = "http://www.hexiwear.com/?utm_source=homepage&utm_campaign=hexiwear-hackster&utm_medium=banner";    
    });
    $('.me-fancy-banner.me-end-of-year-sale-home-banner').click(function(e){
         e.preventDefault();
         window.location = "https://shop.mikroe.com/?utm_source=homepage&utm_campaign=end-of-year-16&utm_medium=banner";    
    });
    $('.me-fancy-banner.me-click-army-home-banner').click(function(e){
         e.preventDefault();
         window.location = "https://shop.mikroe.com/click";    
    });
    $('.me-fancy-banner.me-pic-compiler-home-banner').click(function(e){
         e.preventDefault();
         window.location = "http://www.mikroe.com/seventh-version-pic-compiler-time-christmas/";    
    });
    $('.me-fancy-banner.me-mikrolab-home-banner').click(function(e){
         e.preventDefault();
         window.location = "https://shop.mikroe.com/kits/mikrolab-kits?utm_source=homepage&utm_campaign=mikrolab&utm_medium=banner&utm_content=button";    
    });
    $('.me-fancy-banner.me-wireless-clicks-home-banner').click(function(e){
         e.preventDefault();
         window.location = "https://shop.mikroe.com/click/wireless-connectivity?utm_source=homepage&utm_campaign=wireless-clicks&utm_medium=banner";
    });
    $('.me-fancy-banner.me-gsm-gnss-click-home-banner').click(function(e){
         e.preventDefault();
         window.location = "https://shop.mikroe.com/click/wireless-connectivity/gsm-gnss?utm_source=homepage&utm_campaign=gsm-gnss&utm_medium=banner";
    }); 
    $('.me-fancy-banner.me-compiler-libraries-home-banner').click(function(e){
         e.preventDefault();
         window.location = "https://shop.mikroe.com/compilers?utm_source=homepage&utm_campaign=500-libraries&utm_medium=banner";
    });
        $('.me-fancy-banner.me-mikromedia-home-banner').click(function(e){
         e.preventDefault();
         window.location = "https://shop.mikroe.com/smart-displays/mikromedia?utm_source=homepage&utm_campaign=mikromedia&utm_medium=banner";
    });
        $('.me-fancy-banner.me-easy-boards-home-banner').click(function(e){
         e.preventDefault();
         window.location = "https://shop.mikroe.com/development-boards/full-featured/easy-boards?utm_source=homepage&utm_campaign=easy-boards&utm_medium=banner";
    });
        $('.me-fancy-banner.me-toolchains-home-banner').click(function(e){
         e.preventDefault();
         window.location = "https://shop.mikroe.com/?utm_source=homepage&utm_campaign=complete-solution&utm_medium=banner";
    });
    $('.me-promo-shop .flip-box .ifb-face.ifb-back').click(function(e){
         e.preventDefault();
         window.location = "https://shop.mikroe.com/";    
    });
    $('.me-promo-learn .flip-box .ifb-face.ifb-back').click(function(e){
         e.preventDefault();
         window.location = "http://learn.mikroe.com/";    
    });
    $('.me-promo-libstock .flip-box .ifb-face.ifb-back').click(function(e){
         e.preventDefault();
         window.location = "http://libstock.mikroe.com/project_categories/";    
    });
    $('.me-promo-about .flip-box .ifb-face.ifb-back').click(function(e){
         e.preventDefault();
         window.location = "http://www.mikroe.com/about/";    
    });
    $('.me-promo-toolchains .flip-box .ifb-face.ifb-back').click(function(e){
         e.preventDefault();
         window.location = "http://www.mikroe.com/toolchains/";    
    });
    $('.me-promo-pollution-click').click(function(e){
         e.preventDefault();
         window.location = "https://shop.mikroe.com/click/sensors/pollution";    
    });
    $('.me-promo-skywire-click').click(function(e){
         e.preventDefault();
         window.location = "https://shop.mikroe.com/click/adapter/skywire";    
    });
    $('.me-promo-gsm-gnss-click').click(function(e){
         e.preventDefault();
         window.location = "https://shop.mikroe.com/click/wireless-connectivity/gsm-gnss";    
    });
    $('.me-promo-easypic-v7').click(function(e){
         e.preventDefault();
         window.location = "https://shop.mikroe.com/development-boards/full-featured/easy-boards/easypic";    
    });
        $('.me-promo-hmi-mikromedia').click(function(e){
         e.preventDefault();
         window.location = "https://shop.mikroe.com/smart-displays/mikromedia-hmi";    
    });
        $('.me-promo-click-boards').click(function(e){
         e.preventDefault();
         window.location = "https://shop.mikroe.com/click";    
    });
        $('.me-promo-mikrolab').click(function(e){
         e.preventDefault();
         window.location = "https://shop.mikroe.com/kits/mikrolab-kits";    
    });
});</script><script type="text/javascript">(function() {function addEventListener(element,event,handler) {
	if(element.addEventListener) {
		element.addEventListener(event,handler, false);
	} else if(element.attachEvent){
		element.attachEvent('on'+event,handler);
	}
}function maybePrefixUrlField() {
	if(this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if( urlFields && urlFields.length > 0 ) {
	for( var j=0; j < urlFields.length; j++ ) {
		addEventListener(urlFields[j],'blur',maybePrefixUrlField);
	}
}/* test if browser supports date fields */
var testInput = document.createElement('input');
testInput.setAttribute('type', 'date');
if( testInput.type !== 'date') {

	/* add placeholder & pattern to all date fields */
	var dateFields = document.querySelectorAll('.mc4wp-form input[type="date"]');
	for(var i=0; i<dateFields.length; i++) {
		if(!dateFields[i].placeholder) {
			dateFields[i].placeholder = 'YYYY-MM-DD';
		}
		if(!dateFields[i].pattern) {
			dateFields[i].pattern = '[0-9]{4}-(0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-9]|3[01])';
		}
	}
}

})();</script>
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://www.mikroe.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css?ver=20121024' type='text/css' media='all' />
<![endif]-->







<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>

<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201706'></script>


<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>








<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.mikroe.com\/wp-admin\/admin-ajax.php","nonce":"9127f14144","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/www.mikroe.com\/wp-login.php?redirect_to=https%3A%2F%2Fwww.mikroe.com%2Ftalking-clock-project-text-speech-click%2F","blog_id":"1","local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>

<script type='text/javascript'>
/* <![CDATA[ */
var mc4wp_forms_config = [];
/* ]]> */
</script>

<!--[if lte IE 9]>
<script type='text/javascript' src='https://www.mikroe.com/wp-content/plugins/mailchimp-for-wp/assets/js/third-party/placeholders.min.js?ver=4.0.13'></script>
<![endif]-->

<!-- JS generated by theme -->

<script>
    

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[7000]");
                });
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://www.mikroe.com/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://www.mikroe.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>

<script type='text/javascript' src='https://stats.wp.com/e-201706.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.6',blog:'119890828',post:'7000',tz:'1',srv:'www.mikroe.com'} ]);
	_stq.push([ 'clickTrackerInit', '119890828', '7000' ]);
</script>
<script src="https://www.mikroe.com/wp-content/cache/min/1/230f45e4266b3c72172a11517539db1d.js" data-minify="1"></script><script src="https://www.mikroe.com/wp-content/cache/min/1/1defdd80dd2c52d2d60de08865cd3911.js" data-minify="1"></script><script src="https://www.mikroe.com/wp-content/cache/min/1/4056bcbbc4e429953d27ce84a90e1e38.js" data-minify="1"></script><script src="https://secure.gravatar.com/js/gprofiles.js" data-minify="1"></script><script src="https://www.mikroe.com/wp-content/cache/min/1/86dffd8a668e00ea149383ed00caa955.js" data-minify="1"></script><script src="https://www.mikroe.com/wp-content/cache/min/1/ccba931797ade307e28944b4929d1bd3.js" data-minify="1"></script>
</body>
</html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1486727206 -->