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The mikroC for 8051 organizes applications into projects consisting of a single project
file (extension .mcproj) and one or more source files (extension .c). MikroC for 8051 IDE
allows you to manage multiple projects (see Project Manager). Source files can be com-
piled only if they are part of a project.

The project file contains the following information:

Project name and optional description;
Target device;

Memory model;

Device flags (configuration word);
Device clock;

List of the project source files;

Header files (*.h);

Binary files (*.mcl);

Image files; and

Other files.
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Note that the project doesn'’t include files in the same way as preprocessor does. For
more inormation, see Add/Remove Files from Project.
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In this simple project demonstration, we will create a new project, write some code, compile
it with mikroC for 8051 and test the results. Our example will make LED diodes blink so it
can be easily tested on the 8051 microcontrollers.
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You will need the the connection scheme shown above to test the code for the 8051 micro-
controller. LED diodes are connected to Port PO. In this example you can use any other port
because this simple program will change the state of all ports in the same way. Prior to start,
you have to go through the three basic steps:

Step 1: Install the compiler
Install the mikroC for 8051 compiler. Desktop shorcut and start menu shortcuts will be created.

Step 2: Run the compiler
Run the mikroC for 8051 compiler. The mikroC for 8051 IDE (Integrated development
Environment) will appear.

Step 3: Create a New Project

The easiest way to create a project is by means of the New Project

Wizard, drop-down menu Project > New Project or by clicking the % s#spesm  asmeit
-l

icon New Project from Project Toolbar. e

=+ Cloan Project Polder. ..
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T Remove Fle From Project

Click here to start a new project ——— | tewrurt.. setscin

% CpenProject... Shit+Quked

Ctrlfg

SOFTWARE AND HARDWARE soLUTIONS For emeeppepwortd ) MilkroElektronika



New Project Wizard Steps

The first window provides basic
information on project settings
which will be applied in the follow-
ing steps.

Step 1: From the Device drop-
down list, select a microcontroller
you want to write a code for.

Step 2: Enter the oscillator fre-
quency value.
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Welcome to the New Project
Wizard

This wizard helps you:

= Create a new project

= Select the device for your project

» Setup device clock and choose device flags
» Select desired memory model

« Add project files

Click Next to continue

Hext & Lancel

New Project Wizard

Step 1/6

Select the device you want to use,

@ Back Hext & Lancel

New Project Wizard

Step 2/6
L

Setup the clock, for example 11,0592 MHz.

Device Clock: 10.000000| MHz

Cancel
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Step 3: Select the desired mem-
ory model.

Step 4: Specify the location where
your project will be saved.

Step 5: Add project files to the
project if they are avaiable at this
point. You can always add project
files later using Project Manager.

New Project Wizard

Step 3/6

Choose one of the available memory models.

Mermory Model
(& Smal ) Compact O Large

@ Back Hext % Lancel

Sovej | ) Frst Project ¥ OFirE
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Add project files if they are available at this poin!
You can always add project files later using the Project mnmr in IDE.

Add e To Project:
Di\ProjectsiFirst ProjectiDefinit.h Add
Fibe Naseen
DeProjectsiFirst Project|Defint.h
Eamove
Remove All
@ Back Hext & Lancel
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Step 6: Click Finish and IDE will

New Project Wizard

create the project file and an on /e
accompanying source files named You have successfully created a new project. Click Finish to save the changes
the same as your pl’OjeCt. and to close the wizard.

D

@ Back Enish Lancel
A new .empty source.file will be | ¢ projectc 23
automatically opened in the Code 1 Bvoid main() (
Editor so you can start writing the . T
source code. B g
< >
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This is the source code that will make all microcontroller’s I/O pins to change their logic
state every second. Since LED are conected to the Port PO, they will blink at the same

on
on
on

on

PORTO
PORT1

n PORT2

PORTS

PORTO
PORT?
PORTZ
PORT3

rate.

2] edsinking.c
L PORTO, PORT1, PORTZ and PORTS3.
=, * Test configuration:
L MCU: AT8958253
n Dev.Board: EasyS051B
- Oscillator: External Clock 10.0000 MHz
E Ext. Modules: =
L SW: mikroC for 8051 vi.0
3 * NOTES:
'y None.
20 "
+ Blvoid main() {
* E do {
. PO = Ox00; /4 Turn ON diodes
- P1 = Ox00; A/ Turn ON diodes
L) P2 = Ox00; // Turn ON diodes
. P3 = Ox00: /4 Turn ON diodes
B Delay_ms(1000) 2 // 1 second delay
e PO = OxFF; // Turn OFF diodes
30 P1 = OxFF: /4 Turn OFF diodes
£ P2 = OxFF; // Turn OFF diodes
g P3 = OxFF; // Turn OFF diodes
. Delay_ms (1000) /4 1 second delay
35 } while(1): /¢ Endless loop
= k)
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Compilation

When you have created the project and have written the source code, it's time to com-
pile it. Select Project » Build from the drop-down menu or click the Build Icon from the
Project Toolbar. If more than one project is opened you can compile all open projects
by selecting Project » Build All from the drop-down menu, or click the Build All Icon
from the Project Toolbar.

If there are some errors, you will be notified in the Message Window. If no errors are
encountered, the mikroC for 8051 will generate output files.

Output Files
Upon successful compilation, the mikroC for 8051 will generate output files in the proj-

ect folder (folder which contains the project file .mcproj). Output files are summarized in
the table below:

Format Description File Type
Intel HEX Intel style hex records. Use this file to program 8051 MCU. .hex
Bi mikro Compiled Library. Binary distribution of application that can be
inary . . - .mcl
included in other projects.
- Overview of 8051 memory allotment: instruction addresses, registers,
List File . st
routines and labels.
Assembler File Et;{nFa:lr; readable assembly with symbolic names, extracted from the asm

Assembly View

After compiling the program in the mikroC for 8051, you can click the View Assembly
icon or select Project » View Assembly from the drop-down menu to review the gener-
ated assembly code (.asm file) in a new tab window. Assembly language uses simbolic
names and is much easier to understand, therefore.
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Customizing Projects

Edit Project

You can change basic project settings such as type of chip, oscillator frequency and mem-
ory model in the Project Settings window. Any change in the Project Setting window affects
only currently active project which means that if more than one project is opened, you have
to ensure that the right project is set as active one in the Project Manager.

Managing Project Group

The mikroC for 8051 IDE provides a convenient option which enables several projects to
be opened simultaneously. If you have several projects being related in some way, you
can create a project group.

The project group may be saved by clicking the Save Project Group icon in the Project
Manager window. It may also be reopend by clicking the Open Project Group icon. All rel-
evant data about the project group is stored in the project group file (extension .mpgroup).

Add/Remove Files from Project

The project can contain the following file types:
QB®m A 3 ad
» .c source files; SR P1_T6963C_240x128.mepro |
» .h header files; TR o e
» .mcl binary files; ﬂmc
» .pld project level defines files (future upgrade); = L Header Fies
» image files; ) soLvepeach
» .hex, .asm and .Ist files, see output files. These files —-:mx“m
cannot be added or removed from project; and ) Output Fies
» other files. Ottt Pl

The list of relevant source files is stored in the project file (extension .mcproj).

To add source file to the project, click the Add File to Project icon. Each added source
file must be self-contained, i.e. must have all necessary definitions after preprocessing.

To remove file(s) from the project, click the Remove File from Project icon.

Note
To include the header files (extension .h), use the preprocessor directive #include. See
File Inclusion for more information.
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Source files containing C code should have extension .c. The list of source files relevant
to the application is stored in the project file with extension .mcproj, along with other proj-
ect information. You can compile source files only if they are part of the project.

Creating new source file
To create a new source file, do the following:

Select File » New Unit from the drop-down menu, or press CTRL+N, or click the New File
icon from File Toolbar.

A new tab will be opened. It is a new source file. Select File » Save from the drop-down
menu, or press CTRL+S, or click the Save File icon from File Toolbar and name it as you
want.

If you use New Project Wizard, an empty source file, named after the project with exten-
sion .c, will be created automatically. The mikroC 8051 doesn’t require you to have a
source file named the same as the project, it’s just a matter of convenience.

Opening an existing file

Select File » Open from the drop-down menu, or press CTRL+O, or click the Open File
icon from the File Toolbar. In Open dialog browse to the location of the file that you want
to open, select it and click the Open button.

The selected file is displayed in its own tab. If the selected file is already opened, its cur-
rent Editor tab will become active.

Printing an open file

Make sure that the window containing the file you want to print is an active window.
Select File » Print from the drop-down menu or press CTRL+P.

In the Print Preview Window, set a desired layout of the document and click the OK but-
ton. The file will be printed on the selected printer.

Note

Use the preprocessor directive #include to include header files with extension .h. Do
not rely on the preprocessor to include source files other than headers. See
Add/Remove Files from Project for more information.
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Saving file

Make sure that the window containing the file that you want to save is active.
Select File » Save from the drop-down menu, or press Ctrl+S, or click the Save File icon
from File Toolbar.

Saving file under a different name

Make sure that the window containing the file that you want to save is active.

Select File » Save As from the drop-down menu. The New File Name dialog will be dis-
played.

In the dialog, browse to the folder in which you want to save the file.

In the File Name field, modify the name of the file you want to save.

Click the Save button.

Closing file

Make sure that the tab containing the file that you want to close is the active tab.
Select File » Close from the drop-down menu, or right click the tab of the file that you
want to close and select the Close option from menu.

If the file has been changed since it was last saved, you will be prompted to save your
changes.

Clean Project Folder

This menu gives you possibility to choose
which files from your CUITENt DroOJECt YOU |sirrated by e compier and hay con oo asily eciasted ahen

project is rebuilt,
want to delete. ) )
Select which files you want to remove from the project folder. Please note
ithat selected files will be permanently deleted from your disk if you click

-~

Select the files you want to remove from
the project and click Clean. Please note
that only files marked in bold are generated

by compiler and can be recreated after ﬂzﬁﬁiﬁmm
compiling. R
7] SP1_TE963C_240x128.det

[~] SPI_TB963C_240s1 28.dit
(] SP1_TE963C_240m128.hew

(] 5P1_Te963C_240128.d

(4] SP1_TBOGIC_240w128.Ist

(] SP1_TE963C_2401 28.meprof

(] SPI_TE063C_240 128, user e w

Clean Cancel

:|Program Fies|Mbvoelebtronikaimkso B051\ExamplestSP1 TEAGICLSPT TEAEIC 240x]
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DEVELOPMENT TOOLS | COMPILERS | BOOKS

If you are experiencing problems with any of our product or you just want additional information, please let us know.
TECHNICAL SUPPORT: www.mikroe.com/en/support

If you have any question, comment or business proposal, please contact us.

web:  www.mikroe.com

e-mail: office@mikroe.com




