CREATING THE FIRST PROJECT IN
mikroPascal PRO for AVR
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The mikroPascal PRO for AVR organizes applications into projects consisting of a single
project file (file with the .mppav extension) and one or more source files (files with the
.mpas extension). The mikroPascal PRO for AVR IDE allows you to manage several
projects at a time. Source files can be compiled only if they are part of the project.

A project file contains:

Project name and optional description;
Target device in use;

Device clock;

List of the project source files;

Binary files (*.mcl);

Image files; and

Other files.
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In this reference guide, we will create a new project, write code, compile it with the mikroPas-
cal PRO for AVR and test the results. The purpose of this example is to make LED diodes
on the microcontroller PORTA blink, which will be easy to test on AVR microcontrollers.
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Hardware Connection

For the purpose of testing this example on an AVR microcontroller, it is necessary to connect
hardware as per schematic below. LED diodes are connected to PORTA only. However, you
can use any other port because this simple program will change the state of all ports in the
same way.
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Prior to creating a new project, it is necessary to do the following:

Step 1: Install the compiler
Install the mikroPascal PRO for AVR compiler from the product CD:

CD:\zip\mikropascal_pro_avr\mikropascal_pro_avr_setup.exe

Desktop shortcut and start menu shortcut will be automatically created.

Step 2: Start up the compiler

Start up the mikroPascal PRO for AVR compiler by double clicking the appropriate icon. The
mikroPascal PRO for AVR IDE (Integrated Development Environment) will appear on the

screen.

After these two steps you are ready to create a new project.
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The process of creating a new project is very simple. Select the New
Project option from the Project menu as shown in Figure on the left.
The New Project Wizard window appears. It can also be opened by
clicking the New Project icon from the Project toolbar.

| et sancden | <€———— Click here to start a new project

Welcome to the New Project
Wizard

This wizard helps you:

» Create a new project

= Select the device for your project
= Setup device clock

. = Add project files

Click Next to continue

Bext &

Cancel

The New Project Wizard window
will guide you through the process
of creating a new project. The
introductory window of this appli-
cation contains a list of actions to
be performed when creating a
new project. Click Next.

From the Device Name drop-
down list, select the microcon-
troller you want to write a program

Hew Project Step 1:
il Step 1/6
Select the device you want to use,
for.
R e 3
@ Back Next Cancel
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Step 2:
Enter the oscillator frequency
value in the Device Clock field.

Step 3:
Specify the name and location of
the project.

Step 4:

In the event that the project con-
sists of several source files, it is
necessary to specify them all and
include into the project by clicking
the Add button. It is also possible
to add files later in the Project
Manager window.

Hew Project Wizard

Step 2/6

Setup the clock, for example 11.0592 MHz.

Device Clock: 10.000000 | MHz

@ Back Bext &

Cancel

Hew Project Wizard

Step 36
Specify where your project will be saved.

@ Back Bext %

Cancel

Hew Project Wizard

Step 4/6

Add project files if they are available at this point,

You can always sdd project files later using the Project Manager in IDE.

Add File To Project:

add
File Narne
Bemave
Remove All
@ Back Hext & Cancel
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New Project Wizard

Step 5/6

Select inatial Library Manager state.

Irchude Libranes
& Inchude All (Defaut)

1 Inchude Nore (Recomended)

Selecting o ibraries is recomended for new users.

- ¥ Manage:

f eomplstion.

Libary ManagerHelp

Step 5:

Choose between whether to
include all libraries into the project
or not.

 Back Hext %

Cancel

New Project Wizard

Step 6/6

and to close the wizard,

You have successfully created a new project. Click Finish to save the changes

Step 6:
After all, it is necessary to confirm
all selected options by clicking
Finish.

* Back Einish

Cancel

[2) First Project.mpas @3
*  program First_Project:
D { Declarations section )}
C begin
= { Main program }
7 ‘end.
<) =/

After creating the project, a new
blank window to write a program in
will appear. See Figure on the left.
If you use New Project Wizard when
creating a new project, a blank
source file, named after the project
with the .mpas extension, will auto-
matically be created. The mikroPas-
cal PRO for AVR does not require
you to have a source file named the
same as the project, it’s just a mat-
ter of convenience.
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This is the source code that is to make all microcontroller’s 1/O pins to change their logic
state once per second. Any change of the microcontroller's port state can be seen on LEDs.

[2) LedBinking.mpas Za
Tl (-
U * Project name:
& LED Blinking (Simple 'Hello World' project)
O * Copyright:
3 (c) Mikroelektronika, 2008.
0 * Revision History:
% 20080930:
8 - initial release;
L) “ Description:
10 This 1s a simple 'Hello Worla' project. It turns on/off diodes connected to
g | PORTA.
- * Test configuration:
o MNCU: ATmegalé
< Dev.Board: EasyAVRSEA
= Oscillator: External Clock 08.0000 MHz
b7 Ext. Modules: -
s Sw: mikroPascal for AVR PRO
4 * NOTES:
o ~ Make sure you turn ON the PORT LEDs at SWé. (board specific)
20 )

*  program LED_Blinking:

© B begin

C | DDRA := OxFF: // set direction to be output
-I' while TRUE do

& =] begin

0 PORTA := 0x00; // Turn ON diodes on PORTA
I Delay_ms(1000); // 1 second delay
30

<48 PORTA := OxFF: // Turn OFF diodes on PORTA
-1 Delay_ms (1000) // 1 second delay

O end; // Endless loop)

- L ena.

< | >
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Compilation

When the program is written, it is necessary to compile it into a program (.hex) code, by
selecting one of the build options from the Project menu:

» To create a HEX file, select Build (Ctrl+F9) from the Project menu or click the Build
icon from the Project toolbar.

» The Build All Projects (Shift+F9) option builds all files within the project, libraries (if
there is a source code for them) and def files for the chip in use.

» The Build + Program (Ctrl+F11) option is special as it enables the mikroPascal PRO
for AVR compiler to automatically load the program into the microcontroller after
compilation. The process of programming is performed by using the AVRflash pro-
grammer.

All the errors detected during compilation will be shown in the Messages window. If no
errors are encountered, the mikroPascal PRO for AVR compiler will generate output files.

Output Files

The mikroPascal PRO for AVR compiler generates output files in the project folder con-
taining the project file. Output files are summarized in the table below:

Format Description File Type

Intel HEX InFeI hex style records. It is used for programming AVR hex
microcontrollers.

Binary Compiled Library which may be included in other projects. .mcl

Assembler File [ Assembly file with symbolic names. .asm
Overview of AVR memory allotment. The List File represents an

List File extended version of assembly code, i.e. contains addresses of st
instructions, registers, routines and labels.

Assembly Code Overview
After compilation, click the View Assembly icon or select the View Assembly option

from the Project menu to review the generated assembly code in a new window. To
overview the complete List File, select the View Listing option from the same menu.
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Project Settings

Edit Project

By selecting the Project Settings option from the View menu, a new window providing
possibility to change type and clock frequency of the microcontroller, appears. Any change
in this window affects only the currently active project. If more than one project is open,
make sure that the right project is set as active one in the Project Manager.

Project Group

As mentioned before, the mikroPascal PRO for AVR IDE enables several projects to be
opened simultaneously. If there are several projects related to each other in some way,
it is possible to create a project group.

The project group may be saved by clicking the Save Project Group icon in the Project
Manager window. It may also be reopened by clicking the Open Project Group icon in
the same window. All relevant data about the project group is stored in the project group
file (file with the .mpavgroup extension).

Add/Remove Files from Project

A project may contain the following types of files:

» .mpas additional source files;
» .mcl binary files; QREE 35 S S
» .pld project level defines files; BN | cd_curtainmppav |
. N . =] Sources
» image files; _ _ TR Led_Curtainapss
» .hex, .asm and .Ist files. These files cannot be ) Header Fles
added or removed from the project; and j,,m‘w“m
» other files. © Image Fles
= () Output Files
£ Led_Curtain,hex
() Other Files

To add a file to the project, click the Add File to Project option from the Project menu
or click the Add File to Project icon from the Project toolbar. Each added file must be
self-contained, i.e. must have all definitions after preprocessing.

To remove file(s) from the project, click the Remove File from Project option from the
Project menu or click the Remove File from Project icon from the Project toolbar.
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Creating a new source file

In order to create a new source file, it is necessary to select the New Unit option from
the File menu, or press CTRL+N or click the New File icon from the File toolbar. A new
window, i.e. a new source file automatically appears. Select the Save option from the File
menu, or press CTRL+S or click the Save File icon from the File toolbar and name it as
you want.

Opening an existing file

In order to open a saved file, it is necessary to select the Open option from the File
menu, or press CTRL+O or click the Open File icon from the File toolbar. In the Open dia-
log box, browse the location of the file that you want to open, select it and click the Open
button. The file will be automatically displayed in its own window. If such file is already
open, it becomes active.

Printing an active file
First of all, it is necessary to make sure that the file you want to print is active. Select the
Print option from the File menu or press CTRL+P and click the OK button.

In the Print Preview window, set a desired layout of the document and click the Print
icon.
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Saving file

Make sure that the file you want to save is active.
In order to save it, it is necessary to select the Save option from the File menu, or press
Ctrl+S, or click the Save File icon from the File toolbar.

Saving file under different name

Make sure that the file you want to save is active.

In order to save it under different name, it is necessary to select the Save As option from
the File menu. The Save As dialog box will appear. Here you can browse the folder in
which you want to save the file. In the File Name field, modify the name of the file you
want to save and click the Save button.

Closing file

Make sure that the file you want to close is active.

In order to close it, it is necessary to select the Close option from the File menu, or right
click the window of the file you want to close and select the Close option. If the file has
been changed since it was last saved, you will be prompted to save the changes.

Clean Project Folder

The Clean Project Folder option from the [y ®

Project menu gives you a possibilty to_ [t e AU L
choose the files that you want to delete [***™™

Select which files you want to remove from the project folder, Please note

from your current project. that selected files will be permanently deleted from your disk if you click
Select the files you want to delete from the | m B —— -
project and click the Clean button. The | e

selected files will be permanently deleted. | Biseee

Please note that only files in bold are gen- [ Ledunkdng dct
erated by the compiler and can be recreat- | [tedsinkinghex
ed after the process of compilation. ] LedBtinking st

[ Ledinking.user.dic

[ Led_Curtan.c
[ Led_Curtain hex v
Clean Cancel
C:\Program F PRO for AVRIE Systems|
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If you want to leam more about our products, please visit our website: www.mikroe.com

If you are experiencing some problems with any of our products or just need additional information, please place
your ticket at: www.mikroe.com/en/support

If you have any question, comment or business proposal, do not hesitate to contact us: office@mikroe.com




