CREATING THE FIRST PROJECT
in mikroPascal PRO for AVR
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The mikroPascal PRO for AVR organizes applications into projects consisting of a sin-
gle project file (extension .mppav) and one or more source files (extension .mpas). The
mikroPascal IDE allows you to manage multiple projects (see Project Manager). Source
files can be compiled only if they are part of a project.

A project file contains the following information:

Project name and optional description;
Target device;

Device clock;

List of the project source files;

Binary files (*.mcl);

Image files; and

Other files.
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In this manual we will create a new project, write code, compile it with the mikroPascal PRO
for AVR and test the results. Our example will make LED diodes blink and it will be easy to
test it on AVR microcontrollers.

Note that the project does not include files in the same way as preprocessor does. For
more information, see Add/Remove Files from Project and mikroPascal Reference

Guide.
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Hardware Connection

The connection schematic shown below is needed for testing the code for AVR microcon-
troller. LED diodes are connected to PORTA. In this example you can use any other port
because this simple program will change the state of all ports in the same way.
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Prior to start, you have to go through the following steps:

Step 1: Install the compiler
Insert the product CD, CD:\zip\mikropascal_avr and install the mikroPascal PRO for AVR com-
piler. Desktop shortcut and start menu shortcuts will be created.

Step 2: Run the compiler
Run the mikroPascal PRO for AVR compiler. The mikroPascal IDE (Integrated Develop-
ment Environment) will appear.

After these two steps you are ready to create a new project.
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New Project

The process of creating a new project is very simple. Select New Pro- ez

ject from the Project menu as shown in Figure on the right. The New  * *

Chrlfg

Project Wizard window appears. This window can also be open by a wuisem e

clicking the New Project icon from the Project toolbar.

New Project Wizard

The first New Project Wizard win-
dow provides basic information on
the project settings which will be
applied in the following steps.

Step 1: From the Device drop-
down list, select the microcon-
troller you want to write a code for.
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=i Cean Project Folder. ..
J fdd File To Project....
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Click here to start a new project ———— | et st |
& cpenProject... ShiteQried

Hew Project

Welcome to the New Project
Wizard

This wizard helps you:

» Create a new project

= Select the device for your project

= Setup device clock and choose device flags
Select desired memory model

Add project files

Click Next to continue

Hext & Lancel

New Project Wizard

Step 1/5

Select the device you want to use,

& Back Next 9 Lancel
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Step 2: Enter the oscillator fre-
quency value in the Device Clock

field.

Step 3: Specify the name of the
project and location to save the

project in.

Step 4: Add project files to the
project if they are available at this
point. You can always add project
files later using Project Manager.
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New Project Wizard

3
Step 2/5 1
Setup the clock, for example 11.0592 MHz.
@pack | Nexw | Cancel
New Project Wizard X
Step 3/5 |
Specify where your project will be saved.
C:\First ProjectiFirst_Project.mppav
& Back Next % Gancel

New Project Wizard

Step 4/5

Add project files if they are avaiable at this point.
You can always add project files later using the Project Manager in 1DE.
Add File To Project: 5
C:\First Project|Button.mpas. @& |
File Name
C:\Frst Project|Button.mpas
Remcve
Regove All
¢ Back Next Cancel
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Step 5: Click Finish and IDE will
create all necessary project files.

New Project Wizard

You have successfully created a new project. Click Finish to save the changes
and to close the wizard.

S

Y | T Sancel
A new empty source file will be auto- [ First Project. mpas A%
matically opened in the Code Editor so - program First Project:

you can start writing a source code. .

= { Declarations section )

- Bbegin
= { Main program )

end.
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This is the source code that is to make all microcontroller’s 1/O pins to change their logic
state once per second. The change of the microcontroller's port state can be seen on LEDs.

[2) Ledeinking mpas 2@

ol (.

o * Project name:

® LED Blinking (Simple 'Mello World' project)

O * Copyright:

= (c) Mikroelektronika, 2008.

- * Revision History:

O 20080930:

8 - initial release;

O * Description:

10 This is a simple 'Hello World' project. It turns on/off diodes connected to
g | PORTA.

e || * Test configuration:

C MNCU: ATmegalé

C Dev.Board: EasyAVRSA

< Oscillator: External Clock 08.0000 MHz

* Ext. Modules: -

Q SW: mikroPascal for AVR PRO

. * NOTES:

C - Make sure you turn ON the PORT LEDs at SW6. (board specific)
20 1 4

- program LED_Blinking:

* B Dbegin
-l_ DDRA := OxFF: // set direction to be output
< while TRUE do
O] begin
<! PORTA := 0x00; // Turn ON diodes on PORTA
-1 Delay_ms (1000) ; // 1 second delay
30
O PORTA := OxFF; // Turn OFF diodes on PORTA
-I‘ Delay_ms(1000): // 1 second delay
C end; // Endless loop)
O end.
< | >

SOFTWARE AND HARDWARE soLUTIONS For emeeppepwortd ) MilkroElektronika



Compilation

Once you have created the project and have written the source code, it's time to com-
pile it. Choose one of the build options from the Project menu:

» To create a HEX file select Build (Ctrl+F9) from the Project menu or click the Build
icon from the Project toolbar.

» If more than one project is open it is possible to compile them all at once by select-
ing the Build All option from the Project menu, or click the Build All icon from the
Project toolbar.

» The Build+Program (Ctrl+F11) option is very useful. After the code is compiled
mikroPascal PRO will load .hex file in the AVRflash programmer and it will program
your microcontroller.

If there are errors, you will be notified in the Message Window. If no errors are encoun-
tered, the mikroPascal Pro for AVR will generate output files.

Output Files
Upon successful compilation, the mikroPascal will generate output files in the project

folder containing the project file .mppav. The output files are summarized in the table
below:

Format Description File Type
Intel HEX Intel style hex records. Use this file to program AVR MCU. .hex
mikro Compiled Library. Binary distribution of application that can be

Binary included in other projects. ‘mdl
- Overview of AVR memory allotment: instruction addresses, registers,
List File . st
routines and labels.
Assembler File Human readable assembly with symbolic names, extracted from the asm

List File.

Assembly View

After compiling the program in the mikroPascal PRO for AVR, you can click the View
Assembly icon or select View Assembly from the Project menu to review the generat-
ed assembly code (.asm file) in a new tab window. Assembly language uses symbolic
names and is easy to understand.
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Customizing Projects

Edit Project

You can change the project settings such as type of chip and oscillator frequency in the Pro-
Jject Settings window. Any change in this window affects only currently active project. If more
than one project is open, make sure that the right project is set as the active one in the Pro-
Ject Manager.

Managing Project Group

The mikroPascal PRO for AVR IDE provides a convenient option which enables several
projects to be opened simultaneously. If you have several projects being related in some
way, you can create a project group.

The project group may be saved by clicking the Save Project Group icon in the Project
Manager window. It may also be reopened by clicking the Open Project Group icon. All
relevant data about the project group is stored in the project group file (extension

.mpgroup).

Add/Remove Files from Project

The project can contain the following file types:
L A S S s e R R
» .mpas additional source files; SN L cd_Curtain.mppay |
» .mcl binary files; TLR ted oot
» .pld project level defines files; gmﬂn
» image files; 5 Projct level defines
» .hex, .asm and .Ist files, see output files. These files iy jm’,‘:‘;
cannot be added or removed from the project; and 5] Led_Curtain.hex
» other files. G Ot Pl

The list of relevant source files is stored in the project file (extension .mppav).

To add a source file to the project, click the Add File to Project icon. Each added source
file must be self-contained, i.e. must have all necessary definitions after preprocessing.

To remove file(s) from the project, click the Remove File from Project icon.

Note
(See Units section of mikroPascal PRO for AVR Help.
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Source files containing Pascal code should have extension .mpas. The list of source files
relevant to the application is stored in the project file with extension .mppav, along with
other project information. You can compile source files only if they are part of the project.

Creating new source file
To create a new source file, do the following:

Select New Unit from the File menu, or press CTRL+N, or click the New File icon from
the File toolbar.

A new tab will open. It is a new source file. Select Save from the File menu, or press
CTRL*S, or click the Save File icon from the File toolbar and name it as you want.

If you use New Project Wizard, a blank source file, named after the project with exten-
sion .mpas, will be created automatically. The mikroPascal PRO for AVR does not require
you to have a source file named the same as the project, it’s just a matter of conven-
ience.

Opening an existing file

Select Open from the File menu, or press CTRL+O, or click the Open File icon from the
File toolbar. In the Open dialog browse to the location of the file that you want to open,
select it and click the Open button.

The selected file is displayed in its own tab. If the file is already open, its current Editor
tab will become active.

Printing an open file
Make sure that the window containing the file you want to print is active.
Select Print from the File menu or press CTRL+P.

In the Print Preview Window set a desired layout of the document and click the OK but-
ton. The file will be printed on the selected printer.
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Saving file

Make sure that the window containing the file that you want to save is active.
Select Save from the File menu, or press Ctrl+S, or click the Save File icon from the
File Toolbar.

Saving file under different name

Make sure that the window containing the file that you want to save is active.
Select Save As from the File menu. The New File Name dialog will be displayed.
Browse to the folder in which you want to save the file.

In the File Name field modify the name of the file you want to save.

Click the Save button.

Closing file

Make sure that the tab containing the file that you want to close is active.

Select Close from the File menu, or right click the tab of the file that you want to close
and select the Close option.

If the file has been changed since it was last saved, you will be prompted to save your
changes.

Clean Project Folder

This menu gives you a possibility to

choose the flles that you want to delete e fe Bt e LV AL R

from your current project. Grockizirenns

Select which files you want to remove from the project folder. Please note
that selected files will be permanently deleted from your disk if you dlick

Select the files you want to remove from E}m N
the project and click Clean. Please note | Hiaii®
that only files in bold are generated by the | Cwemamca

. [ LEDERINKING hex
compiler and can be recreated after the | D

G [ LepeinanG. kst
process of compilation. O LedBiing.md
[ tedsinking.mpas
i i [ Ledainking, mpas.ini
“Cleaning” the project folder means that | Ctesnareos

. . ] LEDEUINKING. mpproj_calertable.txt

the selected files will be deleted perma- | [Crecsgusede
[“]Led_Curtain.dct
ne nt|Y- [ LED_CURTAINbex
gLed_cmm.m v

Clean Cancel

C:\Progr L PRO for Syst
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DEVELOPMENT TOOLS | COMPILERS | BOOKS

If you are experiencing problems with any of our product or you just want additional information, please let us know.
TECHNICAL SUPPORT: www.mikroe.com/en/support

If you have any question, comment or business proposal, please contact us.

web:  www.mikroe.com

e-mail: office@mikroe.com




