CREATING THE FIRST PROJECT
in mikroG PRO for AVR
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The mikroC PRO for AVR organizes applications into projects consisting of a single proj-
ect file (extension .mcpav) and one or more source files (extension .c). The mikroC PRO
for AVR IDE allows you to manage multiple projects (see Project Manager). Source files
can be compiled only if they are part of a project.

A project file contains the following information:

Project name and optional description;
Target device;

Device clock;

List of the project source files;

Header files (*.h);

Binary files (*.mcl);

Image files; and

Other files.
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In this manual we will create a new project, write code, compile it with the mikroC PRO for
AVR and test the results. Our example will make LED diodes blink and it will be easy to test
it on AVR microcontrollers.

Note that the project does not include files in the same way as preprocessor does. For
more information, see Add/Remove Files from Project and mikroC Reference Guide.
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Hardware Connection

The connection schematic shown below is needed for testing the code for AVR microcon-
troller. LED diodes are connected to PORTA. In this example you can use any other port
because this simple program will change the state of all ports in the same way.
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Prior to start, you have to go through the following steps:

Step 1: Install the compiler
Insert the product CD, CD:\zip\mikroc_avr\ and install the mikroC PRO for AVR compiler. Desk-
top shortcut and start menu shortcuts will be created.

Step 2: Run the compiler
Run the mikroC PRO for AVR compiler. The mikroC PRO for AVR IDE (Integrated Devel-
opment Environment) will appear.

After these two steps you are ready to create a new project.
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New Project

The process of creating a new project is very simple. Select New Pro- ez

ject from the Project menu as shown in Figure on the right. The New  * *

Chrlfg

Project Wizard window appears. This window can also be open by a wuisem e

clicking the New Project icon from the Project toolbar.

New Project Wizard

The first New Project Wizard win-
dow provides basic information on
the project settings which will be
applied in the following steps.

Step 1: From the Device drop-
down list, select the microcon-
troller you want to write a code for.
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it Saarch Paths...
=i Cean Project Folder. ..
J fdd File To Project....

3 Reemove Fia From Project

Click here to start a new project ———— | et st |
& cpenProject... ShiteQried

Hew Project

Welcome to the New Project
Wizard

This wizard helps you:

» Create a new project

= Select the device for your project

= Setup device clock and choose device flags
Select desired memory model

Add project files

Click Next to continue

Hext & Lancel

New Project Wizard

Step 1/5

Select the device you want to use,

& Back Next 9 Lancel
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Step 2: Enter the oscillator fre-
quency value in the Device Clock

field.

Step 3: Specify the name of the
project and location to save the
project in.

Step 4: Add project files to the
project if they are available at this
point. You can always add project
files later using Project Manager.

New Project Wizard

3
Step 2/5 1
Setup the clock, for example 11.0592 MHz.
@pack | Nexw | Cancel
New Project Wizard X
Step 3/5 |
Specify where your project will be saved.
Broject File Nome:
v
@ Back Next 9 Cancel
New Project Wizard 3
Step 4/5 [
Add project files if they are available at this point.
You can always add project files later using the Project Manager in IDE.
Add Eile To Project: B
Cilavr_prolC mathC_math.c @2 |
File Name
Chavr_prolC mathiC_math.c
Bemove
Remove All
& Back Next & Lancel
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Step 5: Click Finish and IDE will
create all necessary project files.

New Project Wizard

You have successfully created a new project. Click Finish to save the changes
and to close the wizard.

S

@ Back Einish Lancel
A new empty source file will be [ Fistprojectc 2@
automatically opened in the Code 1 Bvoid main() (
Editor so you can start writing a Tl
source code.
< >
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This is the source code that is to make all microcontroller’s 1/O pins to change their logic
state once per second. The change of the microcontroller's port state can be seen on LEDs.

2 LedBinking.c #a
+ 1 e projact nama: ~
9 LED Blinkiny (Simple 'Hello World' project)

& * Copyright:

= (c) Mikroslektronika, 2008.

- * Revision History:

* 200809302

x - initial relsase:

= * Description:

10 This is a simple "Hello World' project. It turns on/off dicdes connected to

# PORTA, PORTS, PORTC and PORTD.

* * Test configuration:

- MCu: ATmegale

o Dev. Board: EasyAVESA

- Oscillator: External Clock 08.0000 MHz

£ Ext. Modules: -

% W mikroC PRO for AVR

) * NOTES:

* - Make suce you tuca ON the PORT LEDs at SWé. (board specific)

zol =/

« Bvoid maini)

= DDRA = OxFF; // set direction to be output

= do |

- PORTA = Ox00; // Turn ON diodes on PORTA

. Delay_ma (1000) : /4 1 second delay

* PORTA = OxFF: #/ Turn OFF dicdes on FORTA

30 Delay ms(1000) ¢ 4/ 1 second delay

& 1 while(l); // Endless loop

<y

~

| »
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Compilation

Once you have created the project and have written the source code, it's time to com-
pile it. Choose one of the build options from the Project menu:

» To create a HEX file select Build (Ctrl+F9) from the Project menu or click the Build
icon from the Project toolbar.

» If more than one project is open it is possible to compile them all at once by select-
ing the Build All option from the Project menu, or click the Build All icon from the
Project toolbar.

» The Build+Program (Ctrl+F11) option is very useful. After the code is compiled
mikroC will load .hex file in the AVRflash programmer and it will program your micro-
controller.

If there are errors, you will be notified in the Message Window. If no errors are encoun-
tered, the mikroC PRO for AVR will generate output files.

Output Files
Upon successful compilation, the mikroC PRO for AVR will generate output files in the

project folder containing the project file .mcpav. The output files are summarized in the
table below:

Format Description File Type
Intel HEX Intel style hex records. Use this file to program AVR MCU. .hex
mikro Compiled Library. Binary distribution of application that can be

Binary included in other projects. ‘mdl
- Overview of AVR memory allotment: instruction addresses, registers,
List File . st
routines and labels.
Assembler File Human readable assembly with symbolic names, extracted from the asm

List File.

Assembly View

After compiling the program in the mikroC PRO for AVR, you can click the View Assem-
bly icon or select View Assembly from the Project menu to review the generated
assembly code (.asm file) in a new tab window. Assembly language uses symbolic
names and is easy to understand.
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Customizing Projects

Edit Project

You can change the project settings such as type of chip and oscillator frequency in the Pro-
Jject Settings window. Any change in this window affects only currently active project. If more
than one project is open, make sure that the right project is set as the active one in the Pro-
Ject Manager.

Managing Project Group

The mikroC PRO for AVR IDE provides a convenient option which enables several proj-
ects to be opened simultaneously. If you have several projects being related in some
way, you can create a project group.

The project group may be saved by clicking the Save Project Group icon in the Project
Manager window. It may also be reopened by clicking the Open Project Group icon. All
relevant data about the project group is stored in the project group file (extension

.mpgroup).

Add/Remove Files from Project

The project can contain the following file types:
QBREE 23 9d 2
» .csource files; B P1_16965C_240x128.meproi |
» .h header files; TR o e
» .mcl binary files; 5 w-cc
» .pld project level defines files; = () Haader Fles
» image files; , B st veseach
» .hex, .asm and .Ist files, see output files. These files L) Project level defines
cannot be added or removed from the project; and —ppriend
» other files. ) Other Fles

The list of relevant source files is stored in the project file (extension .mcpav).

To add a source file to the project, click the Add File to Project icon. Each added source
file must be self-contained, i.e. must have all necessary definitions after preprocessing.

To remove file(s) from the project, click the Remove File from Project icon.

Note
To include header files (extension .h), use the preprocessor directive #include. See File
Inclusion for more information.
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Source files containing C code should have extension .c. The list of source files relevant
to the application is stored in the project file with extension .mcpav, along with other proj-
ect information. You can compile source files only if they are part of the project.

Creating new source file
To create a new source file, do the following:

Select New Unit from the File menu, or press CTRL+N, or click the New File icon from
the File toolbar.

A new tab will open. It is a new source file. Select Save from the File menu, or press
CTRL*S, or click the Save File icon from the File toolbar and name it as you want.

If you use New Project Wizard, a blank source file, named after the project with exten-
sion .c, will be created automatically. The mikroC PRO for AVR does not require you to
have a source file named the same as the project, it’s just a matter of convenience.

Opening an existing file

Select Open from the File menu, or press CTRL+O, or click the Open File icon from the
File toolbar. In the Open dialog browse to the location of the file that you want to open,
select it and click the Open button.

The selected file is displayed in its own tab. If the file is already open, its current Editor
tab will become active.

Printing an open file
Make sure that the window containing the file you want to print is active.
Select Print from the File menu or press CTRL+P.

In the Print Preview Window set a desired layout of the document and click the OK but-
ton. The file will be printed on the selected printer.
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Saving file

Make sure that the window containing the file that you want to save is active.
Select Save from the File menu, or press Ctrl+S, or click the Save File icon from the
File Toolbar.

Saving file under different name

Make sure that the window containing the file that you want to save is active.
Select Save As from the File menu. The New File Name dialog will be displayed.
Browse to the folder in which you want to save the file.

In the File Name field modify the name of the file you want to save.

Click the Save button.

Closing file

Make sure that the tab containing the file that you want to close is active.

Select Close from the File menu, or right click the tab of the file that you want to close
and select the Close option.

If the file has been changed since it was last saved, you will be prompted to save your
changes.

Clean Project Folder

This menu gives you a possibility to
choose the files that you want to delete. [oemsde s i B s B e e b e

from your current project. PrOmCis TR,
Select which files you want to remove from the project folder. Please note
that selected files will be permanently deleted from your disk if you click

Select the files you want to remove from lcdl)hnlm.mm —— ) T ~
the project and click Clean. Please note | 5 mcn

that only files in bold are generated by the | Lt

compiler and can be recreated after the | [Hiedsinkingdct

process of compilation. [ LedBtinking hex

“Cleaning” the project folder means that gtmz‘w

the selected files will be deleted perma- | [Eiedssnkingmcpay_callertable.tut
[ Led8trking.user.dc
nently. [ Led_Curtanc

Q Led_Curtain hex v

Clean Cancel

C:\Progran \» PRO for Systems)
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DEVELOPMENT TOOLS | COMPILERS | BOOKS

If you are experiencing problems with any of our product or you just want additional information, please let us know.
TECHNICAL SUPPORT: www.mikroe.com/en/support

If you have any question, comment or business proposal, please contact us.

web:  www.mikroe.com

e-mail: office@mikroe.com




