CREATING THE FIRST PROJECT
in mikroBasic PRO for AVR
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The mikroBasic PRO for AVR organizes applications into projects consisting of a single
project file (extension .mbpav) and one or more source files (extension .mbas). The
mikroBasic PRO for AVR IDE allows you to manage multiple projects (see Project Man-
ager). Source files can be compiled only if they are part of a project.

A project file contains the following information:

Project name and optional description;
Target device;

Device clock;

List of the project source files;

Binary files (*.mcl);

Image files; and

Other files.
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In this manual we will create a new project, write code, compile it with the mikroBasic PRO
for AVR and test the results. Our example will make LED diodes blink and it will be easy to
test it on AVR microcontrollers.

Note that the project does not include files in the same way as preprocessor does. For
more information, see Add/Remove Files from Project and mikroBasic Reference

Guide.
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Hardware Connection

The connection schematic shown below is needed for testing the code for AVR microcon-
troller. LED diodes are connected to PORTA. In this example you can use any other port
because this simple program will change the state of all ports in the same way.

Prior to start, you have to go through the following steps:
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Step 1: Install the compiler
Insert the product CD, CD:\zip\mikrobasic_avr and install the mikroBasic PRO for AVR compil-
er. Desktop shortcut and start menu shortcuts will be created.

Step 2: Run the compiler
Run the mikroBasic PRO for AVR compiler. The mikroBasic IDE (Integrated Develop-
ment Environment) will appear.

After these two steps you are ready to create a new project.
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New Project

The process of creating a new project is very simple. Select New Pro- ez

ject from the Project menu as shown in Figure on the right. The New  * *

Chrlfg

Project Wizard window appears. This window can also be open by a wuisem e

clicking the New Project icon from the Project toolbar.

New Project Wizard

The first New Project Wizard win-
dow provides basic information on
the project settings to be applied
in the following steps.

Step 1: From the Device drop-
down list, select the microcon-
troller you want to write a code for.
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Welcome to the New Project
Wizard

This wizard helps you:

» Create a new project

= Select the device for your project

= Setup device clock and choose device flags
» Select desired memory model

Add project files

Click Next to continue

Hext & Lancel

New Project Wizard

Step 1/5

Select the device you want to use,

& Back Next 9 Lancel
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Step 2: Enter the oscillator fre-
quency value in the Device Clock

field.

Step 3: Specify the name of the
project and location to save the

project in.

Step 4: Add project files to the
project if they are available at this
point. You can always add project
files later using Project Manager.
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New Project Wizard

3
Step 2/5 1
Setup the clock, for example 11.0592 MHz.
Device Clock!
@pack | Nexw | Cancel
New Project Wizard X
Step 3/5 |
Specify where your project will be saved.
C:\First Projectifrst_Project.mbpavl
& Back Next % Gancel
New Project Wizard X
Step 4/5 [
Add project files if they are avaiable at this point.
You can slways add project files later using the Project Manager in IDE.
Add File To Project:
C:\First ProjectiButton.mbas @4 |
Fila Name
C:\Frst Project|Button. mbas
Remove
Regove All
& Back Next % Gancel
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Step 5: Click Finish and IDE will (Srssssmm

create all necessary project files.

You have successfully created a new project. Click Finish to save the changes
and to close the wizard.

S

A new empty source file will open [ First_Project.mbas

automatically in the Code Editor so
you can start writing a source code.

@ Back Einish Sancel
@
1 |program First_Project
s ' Declarations section
= main:
= L7 Main program
. end.
|
>
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This is the source code that is to make all microcontroller’s 1/O pins to change their logic
state once per second. The change of the microcontroller's port state can be seen on LEDs.

() LedBinking.mbas Fa
il .
A ' * Project name:
= X LED _Blinking (Simple "Hello World"™ project)
<N ' * Copyrignt:
> N (c) Mikroelektronika, 2008.
= ' ¢ Revision History:
= & 20080930:
e Y - initial release
v |t # Description:
1000 * This is & simple "Hello World" project. It turns on/off diodes connected to
= . PORTA, PORTB, PORTC and PORTD.
& ' # Test configuration:
% L MCU: ATmegalé
& 2 Dev.Board: EasyAVREA
= X Oscillator: External Clock 08.0000 MHz
© y Ext. Modules: =
\/ G sw: mikroBasic for AVR PRO
& ' ¢ NOTES:
= X - Make sure you turn ON the PORT LEDs at SWé. (board specific)
20 | v o«
*  program LED Blinking
. main:
C DDRA = OxFF ' set direction to be output
. while TRUE
. PORTA = 0x00 * Turn ON dicdes on PORTA
. Delay_ms (1000) ' 1 second delay
30 PORTA = OxFF ' Turn OFF diodes on PORTA
. Delay_ms (1000) ' 1 second delay
wend ' Endless loop)
3 end.
¢ >
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Compilation

Once you have created the project and written the source code, it's time to compile it.
Choose one of the build options from the Project menu:

» To create a HEX file select Build (Ctrl+F9) from the Project menu or click the Build
icon from the Project toolbar.

» If more than one project is open it is possible to compile them all at once by select-
ing the Build All option from the Project menu, or click the Build All icon from the
Project toolbar.

» The Build+Program (Ctrl+F11) option is very useful. After the code is compiled
mikroBasic will load .hex file in the AVRflash programmer and it will program your
microcontroller.

If there are errors, you will be notified in the Message Window. If no errors are encoun-
tered, the mikroBasic PRO for AVR will generate output files.

Output Files

Upon successful compilation, the mikroBasic will generate output files in the project fold-
er containing the project file .mbpav. The output files are summarized in the table below:

Format Description File Type
Intel HEX Intel style hex records. Use this file to program AVR MCU. .hex
mikro Compiled Library. Binary distribution of application that can be
included in other projects.

Overview of AVR memory allotment: instruction addresses, registers, Ist
routines and labels. )
Human readable assembly with symbolic names, extracted from the
List File.

Binary .mcl

List File

Assembler File .asm

Assembly View

After compiling the program in the mikroBasic, you can click the View Assembly icon or
select View Assembly from the Project menu to review the generated assembly code
(.asm file) in a new tab window. Assembly language uses symbolic names and is easy
to understand.

£ MikroElektronika  sorrwaRrE AND HARDWARE SOLUTIONS FOR EMBEDDED WORLD



Customizing Projects

Edit Project

You can change the project settings such as type of chip and oscillator frequency in the Pro-
Jject Settings window. Any change in this window affects only currently active project. If more
than one project is open, make sure that the right project is set as the active one in the Pro-
Ject Manager.

Managing Project Group

The mikroBasic PRO for AVR IDE provides a convenient option which enables several
projects to be open simultaneously. If you have several projects being related in some
way, you can create a project group.

The project group may be saved by clicking the Save Project Group icon in the Project
Manager window. It may also be reopened by clicking the Open Project Group icon. All
relevant data about the project group is stored in the project group file (extension

.mpgroup).
Add/Remove Files from Project

The project can contain the following file types:
Y
= 0 [
Sources

» .mbas additional source file; e it
» .mcl binary files; bt

» _.pId project level defines files; o

» image files; T

» .hex, .asm and .Ist files, see output files. These files oy

cannot be added or removed from the project; and
» other files.

The list of relevant source files is stored in the project file (extension .mbpav).

To add a source file to the project, click the Add File to Project icon. Each added source
file must be self-contained, i.e. must have all necessary definitions after preprocessing.
See Modules section of mikroBasic Pro for AVR Help.

To remove file(s) from the project, click the Remove File from Project icon.
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Source files containing Basic code should have extension .mbas. The list of source files
relevant to the application is stored in the project file with extension .mbpav, along with
other project information. You can compile source files only if they are part of the project.

Creating new source file
To create a new source file, do the following:

Select New Unit from the File menu, or press CTRL+N, or click the New File icon from
the File toolbar.

A new tab will open. It is a new source file. Select Save from the File menu, or press
CTRL*S, or click the Save File icon from the File toolbar and name it as you want.

If you use New Project Wizard, a blank source file, named after the project with extension
.mbas, will be created automatically. The mikroBasic PRO for AVR does not require you to
have a source file named the same as the project, it’s just a matter of convenience.

Opening an existing file

Select Open from the File menu, or press CTRL+O, or click the Open File icon from the
File toolbar. In the Open dialog browse to the location of the file that you want to open,
select it and click the Open button.

The selected file is displayed in its own tab. If the file is already open, its current Editor
tab will become active.

Printing an open file
Make sure that the window containing the file you want to print is active.
Select Print from the File menu or press CTRL+P.

In the Print Preview Window set a desired layout of the document and click the OK but-
ton. The file will be printed on the selected printer.
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Saving file

Make sure that the window containing the file that you want to save is active.
Select Save from the File menu, or press Ctrl+S, or click the Save File icon from the
File Toolbar.

Saving file under different name

Make sure that the window containing the file that you want to save is active.
Select Save As from the File menu. The New File Name dialog will be displayed.
Browse to the folder in which you want to save the file.

In the File Name field modify the name of the file you want to save.

Click the Save button.

Closing file

Make sure that the tab containing the file that you want to close is active.

Select Close from the File menu, or right click the tab of the file that you want to close
and select the Close option.

If the file has been changed since it was last saved, you will be prompted to save your
changes.

Clean Project Folder

This menu gives you a possibility to

T w i i fi S in bold
choose the files that you want to delete [ o i Ly o e esaly Telrested when e

from your current project. o is Tt
Select which files you want to remove from the project folder, Please note
that selected files will be permanently deleted from your disk if you click

Select the files you want to remove from M a
the project and click Clean. Please note | i
that only files in bold are generated by the 3“"“““"‘“:"

. [ LEDBLINKING hex
compiler and can be recreated after the | Cleiingis
_— ) LEDBLINKING Ist
process of compilation. D) tedetrking.mcl
[ Ledetnking.mpas

“Cleaning” the project folder means that %mmmm_‘mum

the selected files will be deleted perma- | LCluedskoguserdc
[¥] Led_Curtaindct
nently. [ LED_CURTAIN hex
[ Led_Curtan.mpas v

Clean Cancel

C:\Progr. 0 foe Syt
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DEVELOPMENT TOOLS | COMPILERS | BOOKS

If you are experiencing problems with any of our product or you just want additional information, please let us know.
TECHNICAL SUPPORT: www.mikroe.com/en/support

If you have any question, comment or business proposal, please contact us.

web:  www.mikroe.com

e-mail: office@mikroe.com




